aboutsummaryrefslogtreecommitdiffstats
path: root/java/eclipse/Makefile
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2019-09-08 15:27:31 +0800
committerpi <pi@FreeBSD.org>2019-09-08 15:27:31 +0800
commit661f136a057203ddd61e9e44760bc70e78dcc82c (patch)
tree7df67bc58abf6363b63cf4fbefb77714db5a748c /java/eclipse/Makefile
parent64cb97bb0c6db6d0b0a90b14d67bc4e53ec2a652 (diff)
downloadfreebsd-ports-gnome-661f136a057203ddd61e9e44760bc70e78dcc82c.tar.gz
freebsd-ports-gnome-661f136a057203ddd61e9e44760bc70e78dcc82c.tar.zst
freebsd-ports-gnome-661f136a057203ddd61e9e44760bc70e78dcc82c.zip
java/eclipse: usablity patch for webkit2-gtk3 issues
- usability patch for PR:238844 (not a fix, but keeps Eclipse usable) - use github.com servers in preference to git.eclipse.org for distfiles PR: 240383 Submitted by: Jonathan Chen <jonc@chen.org.nz> (maintainer)
Diffstat (limited to 'java/eclipse/Makefile')
-rw-r--r--java/eclipse/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index e3b31cc82b93..6139e6eaada9 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -3,6 +3,7 @@
PORTNAME= eclipse
PORTVERSION= 4.12
+PORTREVISION= 1
CATEGORIES= java devel
# Update to git-tag on git.eclipse.org
@@ -37,8 +38,8 @@ ECLIPSE_MODULES=jdt/eclipse.jdt \
equinox/rt.equinox.p2
# Each Eclipse module has its own MASTER_SITE
.for M in ${ECLIPSE_MODULES}
-MASTER_SITES+= https://git.eclipse.org/c/${M}.git/snapshot/:${M:C/[\.\/]//g} \
- https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/${PORTVERSION}/:${M:C/[\.\/]//g}
+MASTER_SITES+= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/${PORTVERSION}/:${M:C/[\.\/]//g} \
+ https://git.eclipse.org/c/${M}.git/snapshot/:${M:C/[\.\/]//g}
DISTFILES+= ${M:C/.*\///}-${ECLIPSE_SUFX}:${M:C/[\.\/]//g}
.endfor