aboutsummaryrefslogtreecommitdiffstats
path: root/java/eclipse
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2005-09-28 20:19:50 +0800
committernork <nork@FreeBSD.org>2005-09-28 20:19:50 +0800
commit8845542862307599485ad7bf63d9df1d77c7ae34 (patch)
treef51e1736947e0670fdff5e20d22aec199f51ce0c /java/eclipse
parentc9dc69dbf32aeab86630c2744172b52b8e647599 (diff)
downloadfreebsd-ports-gnome-8845542862307599485ad7bf63d9df1d77c7ae34.tar.gz
freebsd-ports-gnome-8845542862307599485ad7bf63d9df1d77c7ae34.tar.zst
freebsd-ports-gnome-8845542862307599485ad7bf63d9df1d77c7ae34.zip
o Fix build error with WITH_MOZILA != mozilla.
o Make an Eclipse menu entry visible. (add dependency) o Bump PORTREVISION, accodingly. PR: ports/86649 Submitted by: Panagiotis Astithas <past@ebs.gr>
Diffstat (limited to 'java/eclipse')
-rw-r--r--java/eclipse/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index 5e0a5f23e6a7..4f03c8a12bcd 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -7,7 +7,7 @@
PORTNAME= eclipse
PORTVERSION= 3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= java devel
MASTER_SITES= ${MASTER_SITE_ECLIPSE}
MASTER_SITE_SUBDIR= R-${PORTVERSION}-200506271435
@@ -44,7 +44,7 @@ USE_MOTIF= yes
.else
ECLIPSE_WS= gtk
.if !defined(WITHOUT_MOZILLA)
-.if defined(WITH_MOZILLA)
+.if defined(WITH_MOZILLA) && ${WITH_MOZILLA} != "mozilla"
BROWSER= ${WITH_MOZILLA}
MAKE_MOZILLA= make_mozilla
BUILD_DEPENDS+= ${BROWSER}:${PORTSDIR}/www/${BROWSER}
@@ -66,10 +66,10 @@ MAKE_CAIRO= make_cairo
.if defined(WITHOUT_GNOMEVFS)
MAKE_GNOME=
-USE_GNOME= gtk20 pkgconfig
+USE_GNOME= gtk20 pkgconfig desktopfileutils
.else
MAKE_GNOME= make_gnome
-USE_GNOME= gtk20 gnomevfs2 libgnome libgnomeui pkgconfig
+USE_GNOME= gtk20 gnomevfs2 libgnome libgnomeui pkgconfig desktopfileutils
.endif
.include <bsd.port.pre.mk>
@@ -93,7 +93,7 @@ MAKE_ENV+= BROWSER=${BROWSER} \
MACHINE_ARCH=${MACHINE_ARCH} \
MOTIF_HOME=${X11_HOME}
-PLIST_FILES= bin/eclipse share/gnome/applications/eclipse.desktop
+PLIST_FILES= bin/eclipse share/applications/eclipse.desktop
SWTGTK=${WRKSRC}/plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library
SWTMOTIF=${WRKSRC}/plugins/org.eclipse.swt/Eclipse SWT PI/motif/library
@@ -129,10 +129,13 @@ do-install:
-e "s+%%ECLIPSE_HOME%%+${PORTDESTDIR}+g" \
-e "s+%%PREFIX%%+${PREFIX}+g" \
${FILESDIR}/eclipse.desktop > ${WRKSRC}/eclipse.desktop.tmp
- ${INSTALL_DATA} ${WRKSRC}/eclipse.desktop.tmp ${X11BASE}/share/gnome/applications/eclipse.desktop
+ ${INSTALL_DATA} ${WRKSRC}/eclipse.desktop.tmp ${PREFIX}/share/applications/eclipse.desktop
${INSTALL_PROGRAM} ${WRKSRC}/launchertmp/eclipse ${PREFIX}/eclipse/eclipse
+ @-update-desktop-database
@(cd ${WRKSRC}; ${FIND} -s eclipse -not -type d) >> ${TMPPLIST}
+ @echo '@exec ${PREFIX}/bin/update-desktop-database > /dev/null || /usr/bin/true' >> ${TMPPLIST}
@(cd ${WRKSRC}; ${FIND} -s -d eclipse -type d) \
| ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
+ @echo '@unexec ${PREFIX}/bin/update-desktop-database > /dev/null || /usr/bin/true' >> ${TMPPLIST}
.include <bsd.port.post.mk>