aboutsummaryrefslogtreecommitdiffstats
path: root/java/jdk13-doc/Makefile
diff options
context:
space:
mode:
authortaoka <taoka@FreeBSD.org>1999-03-18 13:16:45 +0800
committertaoka <taoka@FreeBSD.org>1999-03-18 13:16:45 +0800
commitb2aec96d9c9541483effcc7305daf74aa65e6f74 (patch)
tree7222c580da4f79dd8dbf87ca8d496beb98646cd9 /java/jdk13-doc/Makefile
parent43bd78854871443d05917b6fb1a8c9445517d703 (diff)
downloadfreebsd-ports-gnome-b2aec96d9c9541483effcc7305daf74aa65e6f74.tar.gz
freebsd-ports-gnome-b2aec96d9c9541483effcc7305daf74aa65e6f74.tar.zst
freebsd-ports-gnome-b2aec96d9c9541483effcc7305daf74aa65e6f74.zip
Sun's Java Developers Kit documentation
PR: ports/10483 Submitted by: Martti Kuparinen martti.kuparinen@ericsson.com
Diffstat (limited to 'java/jdk13-doc/Makefile')
-rw-r--r--java/jdk13-doc/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/java/jdk13-doc/Makefile b/java/jdk13-doc/Makefile
new file mode 100644
index 000000000000..edf2c9203431
--- /dev/null
+++ b/java/jdk13-doc/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: JDK documentation
+# Version required: 1.1.7
+# Date created: Mon Mar 8 10:10:42 EET 1999
+# Whom: Martti Kuparinen <martti.kuparinen@ericsson.com>
+#
+# $Id$
+#
+
+DISTNAME= jdk117B-doc
+PKGNAME= jdk-doc-1.1.7
+CATEGORIES= lang
+
+MAINTAINER= martti.kuparinen@ericsson.com
+
+RESTRICTED= "This software is under license and export control."
+IS_INTERACTIVE= "Requires manual fetch"
+WRKSRC= ${WRKDIR}/jdk1.1.7B
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+do-fetch:
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+ @echo ''
+ @echo 'You have to fetch the documentation from'
+ @echo ' http://java.sun.com/products/jdk/1.1/docs.html'
+ @echo ''
+ @echo 'Put ${DISTNAME}${EXTRACT_SUFX} in in ${DISTDIR}/ and run make again.'
+ @echo ''
+ @echo 'All this hassle is because of the license and export restrictions'
+ @echo 'as described in'
+ @echo ' http://java.sun.com/feedback/faq/downloading.html'
+ @echo ''
+ @exit 1
+.endif
+
+do-install:
+ ${MKDIR} ${PREFIX}/jdk1.1.7
+ (cd ${WRKSRC} && tar cf - docs) \
+ | (cd ${PREFIX}/jdk1.1.7 && tar xf -)
+
+.include <bsd.port.mk>