aboutsummaryrefslogtreecommitdiffstats
path: root/java/jdk15
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2002-05-03 13:36:11 +0800
committerglewis <glewis@FreeBSD.org>2002-05-03 13:36:11 +0800
commit63d6640b2435c3aab6d3190080d8c1edd69b1ecb (patch)
tree695a677f6889811cd17335f2e03c4c8e28ecdedc /java/jdk15
parent39ad72d6a1d04ae5fe2af52881d53dc2b16ebebb (diff)
downloadfreebsd-ports-gnome-63d6640b2435c3aab6d3190080d8c1edd69b1ecb.tar.gz
freebsd-ports-gnome-63d6640b2435c3aab6d3190080d8c1edd69b1ecb.tar.zst
freebsd-ports-gnome-63d6640b2435c3aab6d3190080d8c1edd69b1ecb.zip
Add a NATIVE_BOOTSTRAP knob which allows people to bootstrap with
an already installed native JDK rather than insisting on the hardcoded Sun Linux JDK as the bootstrapper. This also means that one can remove the Sun Linux JDK after the initial build if so desired. This may be superseded by a more general method of specifying the bootstrap compiler from bsd.java.mk at a later date. Reviewed by: sobomax Approved by: sobomax
Diffstat (limited to 'java/jdk15')
-rw-r--r--java/jdk15/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/java/jdk15/Makefile b/java/jdk15/Makefile
index e4b5c43a114f..2eebfab76289 100644
--- a/java/jdk15/Makefile
+++ b/java/jdk15/Makefile
@@ -35,7 +35,11 @@ WRKSRC= ${WRKDIR}/j2sdk1.3.1/make
JDK_VERSION= 1.3.1
JDK_PATCHSET_VERSION= 6
+.if defined(NATIVE_BOOTSTRAP)
+JDK13DIR?= ${LOCALBASE}/jdk${JDK_VERSION}
+.else
JDK13DIR?= ${LOCALBASE}/linux-jdk${JDK_VERSION}
+.endif
ONLY_FOR_ARCHS= i386
USE_GMAKE= yes