aboutsummaryrefslogtreecommitdiffstats
path: root/java/jdk15
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2002-04-12 12:34:41 +0800
committerglewis <glewis@FreeBSD.org>2002-04-12 12:34:41 +0800
commite7e7a7d2783bf0ca992d8faf9976016972797390 (patch)
tree927652a8e0cd997a3aa37e6e88bf48efe49eac65 /java/jdk15
parent046a28255c3d3fa157d542479ed04b4edcf72b44 (diff)
downloadfreebsd-ports-gnome-e7e7a7d2783bf0ca992d8faf9976016972797390.tar.gz
freebsd-ports-gnome-e7e7a7d2783bf0ca992d8faf9976016972797390.tar.zst
freebsd-ports-gnome-e7e7a7d2783bf0ca992d8faf9976016972797390.zip
Fix user and group ownership of the installed files when they have been
built by someone other than root. Instead of moving the files with tar, move them with cpio and set up ownership. Note that I have not closed the PR as there are 12 other ports named in the PR with this problem. PR: 36411 Submitted by: Alan Eldridge <ports@geeksrus.net> Reviewed by: sobomax Approved by: sobomax
Diffstat (limited to 'java/jdk15')
-rw-r--r--java/jdk15/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/java/jdk15/Makefile b/java/jdk15/Makefile
index 8af8b9a9aebf..986aa29dc1f6 100644
--- a/java/jdk15/Makefile
+++ b/java/jdk15/Makefile
@@ -126,11 +126,11 @@ pre-install:
do-install:
${MKDIR} ${PREFIX}/jdk${JDK_VERSION}
- (cd ${JDKIMAGEDIR} && ${BSD_TAR} -c -f - .) \
- | (cd ${PREFIX}/jdk${JDK_VERSION} && ${BSD_TAR} --unlink -x -f -)
+ cd ${JDKIMAGEDIR} && /usr/bin/find . \
+ | /usr/bin/cpio -pdmu -R ${LIBOWN}:${LIBGRP} ${PREFIX}/jdk${JDK_VERSION}
.if !defined(NODEBUG)
- (cd ${JDKIMAGEDIR_G} && ${BSD_TAR} -c -f - .) \
- | (cd ${PREFIX}/jdk${JDK_VERSION} && ${BSD_TAR} --unlink -x -f -)
+ cd ${JDKIMAGEDIR_G} && /usr/bin/find . \
+ | /usr/bin/cpio -pdmu -R ${LIBOWN}:${LIBGRP} ${PREFIX}/jdk${JDK_VERSION}
.endif
${MKDIR} ${PREFIX}/jdk${JDK_VERSION}/jre/lib/ext