aboutsummaryrefslogtreecommitdiffstats
path: root/java/jflex
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2006-08-23 04:34:34 +0800
committerhq <hq@FreeBSD.org>2006-08-23 04:34:34 +0800
commit1a779b17af7b41c4e8d1d2c93365207c11101ac1 (patch)
tree06fae266a21f3210156d65f40d7bf277af1d7dc0 /java/jflex
parent9b26e133c8786202b5fff3592cebc0f58698fe8a (diff)
downloadfreebsd-ports-gnome-1a779b17af7b41c4e8d1d2c93365207c11101ac1.tar.gz
freebsd-ports-gnome-1a779b17af7b41c4e8d1d2c93365207c11101ac1.tar.zst
freebsd-ports-gnome-1a779b17af7b41c4e8d1d2c93365207c11101ac1.zip
Fix the build by copying needed JAR files at post-extract stage
PR: 101712 Submitted by: maintainer
Diffstat (limited to 'java/jflex')
-rw-r--r--java/jflex/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/java/jflex/Makefile b/java/jflex/Makefile
index 61c4b30970a2..035080f69b5d 100644
--- a/java/jflex/Makefile
+++ b/java/jflex/Makefile
@@ -24,7 +24,7 @@ USE_JAVA= yes
USE_ANT= yes
BUILD_WRKSRC= ${WRKSRC}/src
ALL_TARGET= jar
-MAKE_ENV+= CLASSPATH="${DISTDIR}/JFlex.jar:${DISTDIR}/java_cup.jar:${JAVALIBDIR}/junit.jar"
+MAKE_ENV+= CLASSPATH="${JAVALIBDIR}/junit.jar"
.if !defined(NOPORTDOCS)
PORTDOCS= *
@@ -32,6 +32,11 @@ PORTDOCS= *
SUB_FILES= jflex.sh
+post-extract:
+ ${MKDIR} ${WRKSRC}/tools
+ ${CP} ${DISTDIR}/JFlex.jar ${WRKSRC}/tools/
+ ${CP} ${DISTDIR}/java_cup.jar ${WRKSRC}/tools/
+
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/jflex.sh ${PREFIX}/bin/jflex
${INSTALL_DATA} ${WRKSRC}/lib/JFlex.jar ${JAVAJARDIR}/JFlex.jar