aboutsummaryrefslogtreecommitdiffstats
path: root/java/jikes/Makefile
diff options
context:
space:
mode:
authordillon <dillon@FreeBSD.org>1998-12-11 02:02:53 +0800
committerdillon <dillon@FreeBSD.org>1998-12-11 02:02:53 +0800
commit895f8084a24fd7e494b193672fa2aac705121c2e (patch)
treec3ec5d836c123b2949bfcb01230b791304e57047 /java/jikes/Makefile
parent338a9dd6f724a93f51928c02deb6c163ab3782de (diff)
downloadfreebsd-ports-gnome-895f8084a24fd7e494b193672fa2aac705121c2e.tar.gz
freebsd-ports-gnome-895f8084a24fd7e494b193672fa2aac705121c2e.tar.zst
freebsd-ports-gnome-895f8084a24fd7e494b193672fa2aac705121c2e.zip
Add IBM's open-source jikes package to the ports collection
Diffstat (limited to 'java/jikes/Makefile')
-rw-r--r--java/jikes/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/java/jikes/Makefile b/java/jikes/Makefile
new file mode 100644
index 000000000000..e798bc15c52d
--- /dev/null
+++ b/java/jikes/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: jikes
+# Version required: 0.41
+# Date created: 09 December 1998
+# Whom: Matthew Dillon <dillon@backplane.com>
+#
+# $Id: exp $
+#
+
+DISTNAME= jikes-0.41
+CATEGORIES= lang
+MASTER_SITES= http://www.backplane.com/FreeBSDPorts/
+DISTFILES= ${DISTNAME}.tar.gz
+WRKSRC= ${WRKDIR}/jikesos
+MAN1= jikes.1
+
+MAINTAINER= dillon@backplane.com
+
+# (sufficiently handled by pkg/MESSAGE, but if IBM has an issue then
+# uncomment this section)
+#
+#fetch-depends:
+#
+#.if !defined(READ_IBM_LICENSE)
+# @echo ""
+# @echo "You must read the IBM license prior to using this software,"
+# @echo "then set READ_IBM_LICENSE=YES in /etc/make.conf.local"
+# @echo ""
+# @echo "The license is available at http://www.ibm.com/research/jikes"
+# @false
+#.endif
+
+.include <bsd.port.mk>