aboutsummaryrefslogtreecommitdiffstats
path: root/java/jlint/Makefile
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2001-06-25 12:00:58 +0800
committerkevlo <kevlo@FreeBSD.org>2001-06-25 12:00:58 +0800
commit534c42a653c3619ce8765c1bb6ee89c7f63011ca (patch)
treebc2decd6513b03d3d1b5d52e56bc4de851604244 /java/jlint/Makefile
parent66b48ecf95794a0eea650ba9f8668c89b3a3f61e (diff)
downloadfreebsd-ports-gnome-534c42a653c3619ce8765c1bb6ee89c7f63011ca.tar.gz
freebsd-ports-gnome-534c42a653c3619ce8765c1bb6ee89c7f63011ca.tar.zst
freebsd-ports-gnome-534c42a653c3619ce8765c1bb6ee89c7f63011ca.zip
Initial import of jlint-2.1
Jlint is the Java program analyzer and checker. PR: 28377 Submitted by: Ernst de Haan <ernst@jollem.com>
Diffstat (limited to 'java/jlint/Makefile')
-rw-r--r--java/jlint/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/java/jlint/Makefile b/java/jlint/Makefile
new file mode 100644
index 000000000000..655670e226bd
--- /dev/null
+++ b/java/jlint/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: jlint
+# Date created: June 2, 2001
+# Whom: Ernst de Haan <ernst@jollem.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jlint
+PORTVERSION= 2.1
+CATEGORIES= java
+MASTER_SITES= http://artho.com/jlint/ \
+ http://jollem.com/~ernst/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= ernst@jollem.com
+
+PLIST_SUB+= T=${TARGET_DIR:S/^${PREFIX}\///}
+TARGET_DIR?= ${PREFIX}/bin
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${MKDIR} ${TARGET_DIR}
+ ${CP} ${WRKSRC}/jlint ${TARGET_DIR}
+ ${CP} ${WRKSRC}/antic ${TARGET_DIR}
+ ${CHMOD} 755 ${TARGET_DIR}/jlint ${TARGET_DIR}/antic
+
+.include <bsd.port.post.mk>