aboutsummaryrefslogtreecommitdiffstats
path: root/java/netbeans5/Makefile
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2003-06-08 03:55:11 +0800
committerolgeni <olgeni@FreeBSD.org>2003-06-08 03:55:11 +0800
commitc492a0d9a77478860a7c1c2310b27a719851a9e8 (patch)
treeea908e16716f1d5ae2e0da355f2be94e7f127d5e /java/netbeans5/Makefile
parent4c69c7db6c6f7cdb9ba15724f9c9d0a04414cdda (diff)
downloadfreebsd-ports-gnome-c492a0d9a77478860a7c1c2310b27a719851a9e8.tar.gz
freebsd-ports-gnome-c492a0d9a77478860a7c1c2310b27a719851a9e8.tar.zst
freebsd-ports-gnome-c492a0d9a77478860a7c1c2310b27a719851a9e8.zip
The NetBeans startup script should be patched on -CURRENT only.
The -CURRENT /bin/expr command may get confused when matching regexps against strings that begin with "-", because they are interpreted as command flags. Using "--" as the first flag solves this, but it will in turn confuse -STABLE expr (syntax error), so it looks like there's no common way to do it (that I can think of).
Diffstat (limited to 'java/netbeans5/Makefile')
-rw-r--r--java/netbeans5/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/java/netbeans5/Makefile b/java/netbeans5/Makefile
index a9432727cf8c..0f163fbc8675 100644
--- a/java/netbeans5/Makefile
+++ b/java/netbeans5/Makefile
@@ -30,6 +30,11 @@ DOWNLOAD_URL?= http://www.netbeans.org/download/dev/daily/build200306020100/plat
IGNORE= You must manually fetch the source distribution (${DISTFILES}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
+.if ${OSVERSION} >= 500000
+post-patch:
+ @${CAT} ${FILESDIR}/bin_runide.sh.diff | ${PATCH} ${WRKSRC}/bin/runide.sh
+.endif
+
do-install:
@${MKDIR} ${PREFIX}/netbeans
@${CP} -r ${WRKSRC}/* ${PREFIX}/netbeans