aboutsummaryrefslogtreecommitdiffstats
path: root/java/openjdk8
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-01-18 21:20:31 +0800
committerTijl Coosemans <tijl@FreeBSD.org>2017-01-18 21:20:31 +0800
commit02f27a83b44d4566fd409edc60570ac0734eb63e (patch)
tree62d2805fd9c9c4285034b54a2ccb3f498f302811 /java/openjdk8
parentbddf1289efd81317364118eb60cdc28cc766c3c2 (diff)
downloadfreebsd-ports-gnome-02f27a83b44d4566fd409edc60570ac0734eb63e.tar.gz
freebsd-ports-gnome-02f27a83b44d4566fd409edc60570ac0734eb63e.tar.zst
freebsd-ports-gnome-02f27a83b44d4566fd409edc60570ac0734eb63e.zip
The output of tools like awk, date, sort, tr,... depends on the current
locale set by the user. Add LANG=C and LC_ALL=C at the beginning of bsd.port.mk and export them so all commands are executed with the C locale. LC_ALL=C overrides all other LC_* variables. LANG is used by setlocale(3) as default value for LC_* variables, so normally it isn't used when LC_ALL is set, but there's code out there that looks at LANG directly so it's safer to set it as well. The only commands not captured by this are != assignments before any inclusion of bsd.port.*mk. Introduce USE_LOCALE=<locale> that adds LANG=<locale> and LC_ALL=<locale> to CONFIGURE_ENV and MAKE_ENV so upstream build systems can be executed with a different locale (e.g. USE_LOCALE=en_US.UTF-8). PR: 215882 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'java/openjdk8')
-rw-r--r--java/openjdk8/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/java/openjdk8/Makefile b/java/openjdk8/Makefile
index d4fae8dfa93a..ff5ae60e67f9 100644
--- a/java/openjdk8/Makefile
+++ b/java/openjdk8/Makefile
@@ -197,8 +197,7 @@ SHEBANG_FILES= configure
_MAKE_JOBS= #
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAKE_ENV= LANG="C" LC_ALL="C"
-MAKE_ENV+= CLASSPATH="" JAVA_HOME="" LD_LIBRARY_PATH=""
+MAKE_ENV= CLASSPATH="" JAVA_HOME="" LD_LIBRARY_PATH=""
MAKE_ENV+= IGNORE_OLD_CONFIG=true
MAKE_ENV+= COMPILER_WARNINGS_FATAL="false"
# openjdk8 normally sets X_CFLAGS in the ./configure script, but it won't do