aboutsummaryrefslogtreecommitdiffstats
path: root/java/veditor
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-02-18 02:19:33 +0800
committerantoine <antoine@FreeBSD.org>2014-02-18 02:19:33 +0800
commit6a80b526b1bb8d888bfd2fb3e5e65bd707af9df6 (patch)
tree765e80bb52ac72599c6754ed10c427caeb0c33b9 /java/veditor
parente739af329c19aac5570c60c715320ddb5ec83015 (diff)
downloadfreebsd-ports-gnome-6a80b526b1bb8d888bfd2fb3e5e65bd707af9df6.tar.gz
freebsd-ports-gnome-6a80b526b1bb8d888bfd2fb3e5e65bd707af9df6.tar.zst
freebsd-ports-gnome-6a80b526b1bb8d888bfd2fb3e5e65bd707af9df6.zip
- Stage support
- Use OPTIONS helpers
Diffstat (limited to 'java/veditor')
-rw-r--r--java/veditor/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/java/veditor/Makefile b/java/veditor/Makefile
index ffe935918036..da932d9619f8 100644
--- a/java/veditor/Makefile
+++ b/java/veditor/Makefile
@@ -20,16 +20,8 @@ VERILOG_DESC= Support Verilog with Icarus Verilog
VHDL_VHDL= Support VHDL with FreeHDL
OPTIONS_DEFAULT= VERILOG VHDL
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MVERILOG}
-RUN_DEPENDS+= iverilog:${PORTSDIR}/cad/iverilog
-.endif
-
-.if ${PORT_OPTIONS:MVHDL}
-RUN_DEPENDS+= freehdl-v2cc:${PORTSDIR}/cad/freehdl
-.endif
+VERILOG_RUN_DEPENDS= iverilog:${PORTSDIR}/cad/iverilog
+VHDL_RUN_DEPENDS= freehdl-v2cc:${PORTSDIR}/cad/freehdl
PLIST_SUB= VER=${PORTVERSION} \
ECLIPSE=${ECLIPSE}
@@ -41,8 +33,8 @@ ECLIPSE= lib/eclipse
PLUGINS= plugins
do-install:
- @${MKDIR} ${PREFIX}/${ECLIPSE}/${PLUGINS}
- @${INSTALL_DATA} ${DISTDIR}/${DISTFILES} \
- ${PREFIX}/${ECLIPSE}/${PLUGINS}/
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${ECLIPSE}/${PLUGINS}
+ ${INSTALL_DATA} ${DISTDIR}/${DISTFILES} \
+ ${STAGEDIR}${PREFIX}/${ECLIPSE}/${PLUGINS}
.include <bsd.port.mk>