aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2010-09-09 14:18:08 +0800
committerglewis <glewis@FreeBSD.org>2010-09-09 14:18:08 +0800
commit087a2156fd3e08f325104a1c6b9ff07de766216b (patch)
tree80013e288c682e510840d8083bf23e00fbfc4433 /java
parentc7635a05a9941e8f5d742e6f8e63ac5cba7c5077 (diff)
downloadfreebsd-ports-gnome-087a2156fd3e08f325104a1c6b9ff07de766216b.tar.gz
freebsd-ports-gnome-087a2156fd3e08f325104a1c6b9ff07de766216b.tar.zst
freebsd-ports-gnome-087a2156fd3e08f325104a1c6b9ff07de766216b.zip
. Respect MAKE_JOB_NUMBERS and use that to set up the number of HotSpot
make jobs. If not, fall back to the number of CPUs, as per the current behaviour. Only the HotSpot part of the build is safe to parallelise, so leave the port marked MAKE_JOBS_UNSAFE.
Diffstat (limited to 'java')
-rw-r--r--java/openjdk6/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/java/openjdk6/Makefile b/java/openjdk6/Makefile
index ef2d18e67d11..a211f14726b0 100644
--- a/java/openjdk6/Makefile
+++ b/java/openjdk6/Makefile
@@ -147,8 +147,14 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/X11/fonts/dejavu:${PORTSDIR}/x11-fonts/dejavu
USE_DISPLAY= yes
.endif
-BUILD_JOBS_NUMBER!= ${SYSCTL} -n kern.smp.cpus
+.if !defined(DISABLE_MAKE_JOBS)
+.if defined(MAKE_JOBS_NUMBER)
+BUILD_JOBS_NUMBER= ${MAKE_JOBS_NUMBER}
+.else
+BUILD_JOBS_NUMBER= `${SYSCTL} -n kern.smp.cpus`
+.endif
MAKE_ENV+= HOTSPOT_BUILD_JOBS=${BUILD_JOBS_NUMBER}
+.endif
COPYDIRS= \
hotspot/src/os/linux/launcher \