aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-01-14 01:36:23 +0800
committerjgh <jgh@FreeBSD.org>2012-01-14 01:36:23 +0800
commit2a2b554d9e5ed8fd962fa796a90b94eccbe872b9 (patch)
tree6e7516937a6090fd3eff4950946a415808cf45fc /java
parent70649447dcde24f8e640ce7f460ca6e29c9fadca (diff)
downloadfreebsd-ports-gnome-2a2b554d9e5ed8fd962fa796a90b94eccbe872b9.tar.gz
freebsd-ports-gnome-2a2b554d9e5ed8fd962fa796a90b94eccbe872b9.tar.zst
freebsd-ports-gnome-2a2b554d9e5ed8fd962fa796a90b94eccbe872b9.zip
- Add variable JDK_UPDATE_VERSION for java to 30 (current Oracle release of JDK 6)
This is largely done for java detection for browser compatibility Please update UPDATE_VERSION for new releases PR: ports/163916 Submitted by: Denny Lin <dennylin93 at hs.ntnu.edu.tw> Approved by: glewis, (rene, crees) (mentors,implicit)
Diffstat (limited to 'java')
-rw-r--r--java/openjdk6/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/java/openjdk6/Makefile b/java/openjdk6/Makefile
index 3ff95464d063..86b387f20eab 100644
--- a/java/openjdk6/Makefile
+++ b/java/openjdk6/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openjdk6
PORTVERSION= b24
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= java devel
MASTER_SITES= http://download.java.net/openjdk/jdk6/promoted/${PORTVERSION}/ \
http://download.java.net/jaxp/openjdk/jdk6/:jaxp \
@@ -65,6 +65,7 @@ JAF_BUILD= b20
JAFFILE= jdk6-jaf-${JAF_BUILD}.zip
JTREGVERSION= b03
JTREGFILE= jtreg-4.1-bin-${JTREGVERSION}_11_jul_2011.zip
+UPDATE_VERSION= 30
# do not depend on devel/apache-ant to avoid circular dependency, but
# use .tar.bz2 distfile to avoid duplicated downloads
@@ -122,7 +123,8 @@ MAKE_ENV= LANG=C LC_ALL=C \
ANT_HOME=${WRKDIR}/apache-ant-${ANTVERSION} \
BUILD_NUMBER=${PORTVERSION} \
NO_DOCS=true \
- MILESTONE=fcs
+ MILESTONE=fcs \
+ JDK_UPDATE_VERSION=${UPDATE_VERSION}
.if defined(WITH_DEBUG)
ALL_TARGET= debug_build