aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-17 17:33:41 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-17 17:33:41 +0800
commit71073289bb13c448d7d9805c123cff726c9b4f08 (patch)
tree424a77c23e4a19c8abdbff9b505ce0d7b5d31f84 /java
parent32514b258bd1f6534460a6d4231215638b1f6375 (diff)
downloadfreebsd-ports-gnome-71073289bb13c448d7d9805c123cff726c9b4f08.tar.gz
freebsd-ports-gnome-71073289bb13c448d7d9805c123cff726c9b4f08.tar.zst
freebsd-ports-gnome-71073289bb13c448d7d9805c123cff726c9b4f08.zip
Stagify.
Approved by: portmgr@
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-uml/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/java/eclipse-uml/Makefile b/java/eclipse-uml/Makefile
index d427fea8887e..a3948146f0d9 100644
--- a/java/eclipse-uml/Makefile
+++ b/java/eclipse-uml/Makefile
@@ -23,14 +23,13 @@ USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
-NO_STAGE= yes
do-install:
- @${MKDIR} ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/lib/eclipse
- @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
- @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
- | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${STAGEDIR}${PREFIX}/lib/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
+ @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
+ | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
+ | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
.include <bsd.port.mk>