aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2004-04-03 14:26:11 +0800
committerglewis <glewis@FreeBSD.org>2004-04-03 14:26:11 +0800
commit78f5c5b5e261a53fdfd4be749130387b4b13a994 (patch)
tree0d09c221fb3a8c8630aabeeca48c01fd698b9119 /java
parentf686bfa3a2ded3aca65d4fefa2cf35b90d3afb38 (diff)
downloadfreebsd-ports-gnome-78f5c5b5e261a53fdfd4be749130387b4b13a994.tar.gz
freebsd-ports-gnome-78f5c5b5e261a53fdfd4be749130387b4b13a994.tar.zst
freebsd-ports-gnome-78f5c5b5e261a53fdfd4be749130387b4b13a994.zip
. Fix incompatibilities with the new bsd.java.mk (oops).
JAVA_OS == FreeBSD -> JAVA_PORT_OS == native Bug report by: kris
Diffstat (limited to 'java')
-rw-r--r--java/jai-imageio/Makefile2
-rw-r--r--java/jai/Makefile2
-rw-r--r--java/java3d/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/java/jai-imageio/Makefile b/java/jai-imageio/Makefile
index 25102830e602..57eababa1627 100644
--- a/java/jai-imageio/Makefile
+++ b/java/jai-imageio/Makefile
@@ -33,7 +33,7 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
IGNORE= "You must manually fetch the \"Linux Install\" distribution \(${DISTNAME}${EXTRACT_SUFX}\) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again"
.endif
-.if ${JAVA_OS} == "FreeBSD"
+.if ${JAVA_PORT_OS} == "native"
WITH_PLUGINWRAPPER= yes
RUN_DEPENDS+= ${LOCALBASE}/lib/pluginwrapper/jai.so:${PORTSDIR}/www/linuxpluginwrapper
.endif
diff --git a/java/jai/Makefile b/java/jai/Makefile
index de12fff26556..dcca31befd2b 100644
--- a/java/jai/Makefile
+++ b/java/jai/Makefile
@@ -35,7 +35,7 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
IGNORE= "You must manually fetch the \"Linux CLASSPATH Install\" distribution \(${DISTNAME}${EXTRACT_SUFX}\) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again"
.endif
-.if ${JAVA_OS} == "FreeBSD"
+.if ${JAVA_PORT_OS} == "FreeBSD"
WITH_PLUGINWRAPPER= yes
RUN_DEPENDS+= ${LOCALBASE}/lib/pluginwrapper/jai.so:${PORTSDIR}/www/linuxpluginwrapper
.endif
diff --git a/java/java3d/Makefile b/java/java3d/Makefile
index 7f5675dd0043..98cedebe0dfb 100644
--- a/java/java3d/Makefile
+++ b/java/java3d/Makefile
@@ -36,7 +36,7 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
-.if ${JAVA_OS} == "FreeBSD"
+.if ${JAVA_PORT_OS} == "native"
WITH_PLUGINWRAPPER= yes
RUN_DEPENDS+= ${LOCALBASE}/lib/pluginwrapper/java3d.so:${PORTSDIR}/www/linuxpluginwrapper
.endif