aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-02-16 20:11:29 +0800
committerantoine <antoine@FreeBSD.org>2014-02-16 20:11:29 +0800
commit7ddc444e8289a1d2eb996fcf7f9e076d18aaaa7c (patch)
tree2ab8cc3af9303e23c896286cae0a5266e5c9f23c /java
parent4204f9daaa703ed69bc67a61a3f2a72df4205b2b (diff)
downloadfreebsd-ports-gnome-7ddc444e8289a1d2eb996fcf7f9e076d18aaaa7c.tar.gz
freebsd-ports-gnome-7ddc444e8289a1d2eb996fcf7f9e076d18aaaa7c.tar.zst
freebsd-ports-gnome-7ddc444e8289a1d2eb996fcf7f9e076d18aaaa7c.zip
- Stage support
- Remove infozip dependency
Diffstat (limited to 'java')
-rw-r--r--java/commonclipse/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/java/commonclipse/Makefile b/java/commonclipse/Makefile
index dc71d913b865..678ec7ce5e9e 100644
--- a/java/commonclipse/Makefile
+++ b/java/commonclipse/Makefile
@@ -7,6 +7,7 @@ PORTREVISION= 4
CATEGORIES= java devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}%20for%20eclipse%203.1M6%20and%20up
DISTNAME= net.sf.commonclipse_${PORTVERSION}
+EXTRACT_SUFX= .zip
DIST_SUBDIR= eclipse
MAINTAINER= zhoushuqun@gmail.com
@@ -16,16 +17,14 @@ RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
PLIST_SUB= DISTNAME=${DISTNAME}
-NO_STAGE= yes
do-install:
- @${MKDIR} ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/plugins ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/features ${PREFIX}/eclipse
+ @${MKDIR} ${STAGEDIR}${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/plugins ${STAGEDIR}${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/features ${STAGEDIR}${PREFIX}/eclipse
.include <bsd.port.mk>