aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2011-03-17 19:08:44 +0800
committerpav <pav@FreeBSD.org>2011-03-17 19:08:44 +0800
commit8f24a15726dba3bbbd584e92f3d81b4bd0190d9a (patch)
tree30e57ad4f97668320f2f386f99980504ff4d1f78 /java
parent01b1e104baba5395a22dea3b13bcdf24730d3440 (diff)
downloadfreebsd-ports-gnome-8f24a15726dba3bbbd584e92f3d81b4bd0190d9a.tar.gz
freebsd-ports-gnome-8f24a15726dba3bbbd584e92f3d81b4bd0190d9a.tar.zst
freebsd-ports-gnome-8f24a15726dba3bbbd584e92f3d81b4bd0190d9a.zip
- Mark ports that have been broken for six month or more, or never compiled on
7.X and up, for removal in one month
Diffstat (limited to 'java')
-rw-r--r--java/jdk14/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/java/jdk14/Makefile b/java/jdk14/Makefile
index 10a225555f13..a2458adbb2fe 100644
--- a/java/jdk14/Makefile
+++ b/java/jdk14/Makefile
@@ -27,6 +27,9 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
${LOCALBASE}/include/nspr/prtypes.h:${PORTSDIR}/devel/nspr
RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
+BROKEN= Does not compile with GCC 4.2
+DEPRECATED= does not build on FreeBSD 7.x or newer
+EXPIRATION_DATE=2011-04-17
OPTIONS= DEBUG "Enable debugging support" off \
IPV6 "Enable IPv6 support" off \
@@ -67,10 +70,6 @@ LINUX_BOOTSTRAP_JDKS= ${LOCALBASE}/linux-sun-jdk1.4.2
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
.if defined(WITH_IPV6)
CATEGORIES+= ipv6
.endif