aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2004-09-01 10:46:00 +0800
committerglewis <glewis@FreeBSD.org>2004-09-01 10:46:00 +0800
commit967f1b0794a0663fdbe009f858c16bbc53336af9 (patch)
tree8cfb11f73ac7ae99395405241a48dda63965a6fa /java
parentcf35ce770be7fa8b816ef889b564f17fab512f90 (diff)
downloadfreebsd-ports-gnome-967f1b0794a0663fdbe009f858c16bbc53336af9.tar.gz
freebsd-ports-gnome-967f1b0794a0663fdbe009f858c16bbc53336af9.tar.zst
freebsd-ports-gnome-967f1b0794a0663fdbe009f858c16bbc53336af9.zip
. Clean up all the .orig files from patching and do it in post-patch rather
than do-install. This fixes the packing list.
Diffstat (limited to 'java')
-rw-r--r--java/jdk11/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/java/jdk11/Makefile b/java/jdk11/Makefile
index 80ca11497761..10822eeb7943 100644
--- a/java/jdk11/Makefile
+++ b/java/jdk11/Makefile
@@ -35,8 +35,10 @@ LIB_DEPENDS+= c.3:${PORTSDIR}/misc/compat3x
DISTFILES= jdk${JDK_VERSION}_ELF.V1999-11-9.tar.gz
.endif
+post-patch:
+ ${FIND} ${WRKSRC} -name '*.orig' -delete
+
do-install:
- @${RM} -f ${WRKSRC}/include/freebsd/typedefs_md.h.orig
${MKDIR} ${PREFIX}/jdk${JDK_VERSION}
cd ${WRKSRC} && ${FIND} . \
| ${CPIO} -pdmu -R ${LIBOWN}:${LIBGRP} ${PREFIX}/jdk${JDK_VERSION}