aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-02-16 23:07:26 +0800
committerantoine <antoine@FreeBSD.org>2014-02-16 23:07:26 +0800
commita18545dd9f018ab0d94026463bd5189df3efe8a8 (patch)
treeed32aafd28cf9638a3bd4de7bebdf6bf7a25bf85 /java
parentb7156b76b57cfce82ae1e65d7eb0680065e6b9f3 (diff)
downloadfreebsd-ports-gnome-a18545dd9f018ab0d94026463bd5189df3efe8a8.tar.gz
freebsd-ports-gnome-a18545dd9f018ab0d94026463bd5189df3efe8a8.tar.zst
freebsd-ports-gnome-a18545dd9f018ab0d94026463bd5189df3efe8a8.zip
- Stage support
- Remove infozip dependency
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-hibernatetools/Makefile19
1 files changed, 5 insertions, 14 deletions
diff --git a/java/eclipse-hibernatetools/Makefile b/java/eclipse-hibernatetools/Makefile
index 2b3384be19a2..256fd0720ac6 100644
--- a/java/eclipse-hibernatetools/Makefile
+++ b/java/eclipse-hibernatetools/Makefile
@@ -8,43 +8,34 @@ CATEGORIES= java devel databases
MASTER_SITES= SF/jboss/JBossTools/JBossTools%202.1.2.GA
PKGNAMEPREFIX= eclipse-
DISTNAME= HibernateTools-${DISTVERSION}
+EXTRACT_SUFX= .zip
DIST_SUBDIR= eclipse
MAINTAINER= ports@FreeBSD.org
COMMENT= Hibernate3 Tools for the Eclipse IDE
+LICENSE= EPL LGPL3
+LICENSE_COMB= multi
+
## XXX - Notify the maintainer if the dependencies on either
## java/eclipse-gef of java/eclipse-webtools change
RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
${LOCALBASE}/share/eclipse/dropins/gef:${PORTSDIR}/java/eclipse-gef \
${LOCALBASE}/share/eclipse/dropins/webtools:${PORTSDIR}/java/eclipse-webtools
-LICENSE= EPL LGPL3
-LICENSE_COMB= multi
-
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
-NO_STAGE= yes
post-extract:
# avoid empty dirs since they break the automated PLIST generation
@${FIND} ${WRKSRC} -type d -empty \
-exec ${TOUCH} "{}/.keep_me" \;
do-install:
-# create destination dir
- @${MKDIR} ${PREFIX}/lib/eclipse
-# install both files and directories
- @(cd ${WRKSRC} && \
- ${FIND} -s features plugins -type d \
- -exec ${MKDIR} "${PREFIX}/lib/eclipse/{}" \; && \
- ${FIND} -s features plugins -not -type d \
- -exec ${INSTALL_DATA} "{}" "${PREFIX}/lib/eclipse/{}" \; \
- )
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "features plugins" ${STAGEDIR}${PREFIX}/lib/eclipse)
# used to manually generate the plist files
generate-plist-locally: build