aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2010-07-16 20:36:22 +0800
committerglewis <glewis@FreeBSD.org>2010-07-16 20:36:22 +0800
commita9097c9453eb61158b6f65393317feb3183c67b6 (patch)
tree1e7867a3a2eea33e631ea708071ba830d87e2dfb /java
parent6216ef2314bd844ec7f650b8e6525906707a0a92 (diff)
downloadfreebsd-ports-gnome-a9097c9453eb61158b6f65393317feb3183c67b6.tar.gz
freebsd-ports-gnome-a9097c9453eb61158b6f65393317feb3183c67b6.tar.zst
freebsd-ports-gnome-a9097c9453eb61158b6f65393317feb3183c67b6.zip
. Update installation paths for the new version of eclipse.
PR: 148670 Approved by: Sutra Zhou <zhoushuqun@gmail.com> (MAINTAINER)
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-shelled/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/java/eclipse-shelled/Makefile b/java/eclipse-shelled/Makefile
index 6f3331ee5c9e..83d8e7bbb764 100644
--- a/java/eclipse-shelled/Makefile
+++ b/java/eclipse-shelled/Makefile
@@ -30,13 +30,13 @@ do-install:
@${MKDIR} ${WRKSRC}/eclipse
@${MV} ${WRKSRC}/plugins ${WRKSRC}/eclipse/plugins
@${MV} ${WRKSRC}/features ${WRKSRC}/eclipse/features
- @${MKDIR} ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/eclipse
- @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) >> ${TMPPLIST}
+ @${MKDIR} ${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/lib/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
@(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
| ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
+ | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
@${MV} ${WRKSRC}/eclipse/plugins ${WRKSRC}/plugins
@${MV} ${WRKSRC}/eclipse/features ${WRKSRC}/features
@${RM} -rf ${WRKSRC}/eclipse