aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorEugene Grosbein <eugen@FreeBSD.org>2019-04-04 02:07:41 +0800
committerEugene Grosbein <eugen@FreeBSD.org>2019-04-04 02:07:41 +0800
commitbfca5d2c6e01d757f1f37c141c22645c2835104b (patch)
tree92d403f664c78e7f25bcdf12405b8c5c4746ef95 /java
parent5650efc84a3a7dab95bc4f766b6457e3f5bae50a (diff)
downloadfreebsd-ports-gnome-bfca5d2c6e01d757f1f37c141c22645c2835104b.tar.gz
freebsd-ports-gnome-bfca5d2c6e01d757f1f37c141c22645c2835104b.tar.zst
freebsd-ports-gnome-bfca5d2c6e01d757f1f37c141c22645c2835104b.zip
java/bouncycastle15: install signed bcprov.jar
Previous revision 497549 switched to install bcprov.jar build from sources instead of bundled version. However, the bundled version of JAR file is signed that is essential as is provides an implementation of a Provider in the Java Cryptography Architecture. For details, refer to https://docs.oracle.com/javase/8/docs/technotes/guides/security/crypto/HowToImplAProvider.html Partially back out that revision to install bundled bcprov.jar as before. Thanks to Alex Dupre for reporting this. Reported by: ale
Diffstat (limited to 'java')
-rw-r--r--java/bouncycastle15/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/java/bouncycastle15/Makefile b/java/bouncycastle15/Makefile
index a8ca05197b36..2bfdb5af955f 100644
--- a/java/bouncycastle15/Makefile
+++ b/java/bouncycastle15/Makefile
@@ -3,6 +3,7 @@
PORTNAME= bouncycastle
PORTVERSION= 1.61
+PORTREVISION= 1
CATEGORIES= java security
MASTER_SITES= http://www.bouncycastle.org/download/ \
http://polydistortion.net/bc/download/
@@ -55,6 +56,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/build/artifacts/jdk${JDKMVERSION}/jars/${jar}-jdk${JDKNVERSION}on-${DVERSION}.jar \
${STAGEDIR}${JAVAJARDIR}/${jar}.jar
.endfor
+ ${INSTALL_DATA} ${WRKSRC}/jars/bcprov-jdk${JDKNVERSION}on-${DVERSION}.jar \
+ ${STAGEDIR}${JAVAJARDIR}/bcprov.jar
.if ${PORT_OPTIONS:MZIPSRC}
@${MKDIR} ${STAGEDIR}${DATADIR}
.for jar in ${JARS_SRC}