aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2015-12-15 07:20:05 +0800
committerjkim <jkim@FreeBSD.org>2015-12-15 07:20:05 +0800
commitc467a6437fb9527be5e5cf4ef48883a39a5a68f5 (patch)
tree28c39a9c6f61c603f495f5040d2aacd8fe7cc5b4 /java
parente3700e950ea92379a0e927d480d287d8ff155e93 (diff)
downloadfreebsd-ports-gnome-c467a6437fb9527be5e5cf4ef48883a39a5a68f5.tar.gz
freebsd-ports-gnome-c467a6437fb9527be5e5cf4ef48883a39a5a68f5.tar.zst
freebsd-ports-gnome-c467a6437fb9527be5e5cf4ef48883a39a5a68f5.zip
Build with sjavac when we are self-hosting to improve build speed.
Diffstat (limited to 'java')
-rw-r--r--java/openjdk8/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/java/openjdk8/Makefile b/java/openjdk8/Makefile
index b3ed018e987f..6654a7e0c1f7 100644
--- a/java/openjdk8/Makefile
+++ b/java/openjdk8/Makefile
@@ -330,6 +330,10 @@ BUILD_DEPENDS+= ${BOOTSTRAPJDKDIR}/bin/javac:${PORTSDIR}/java/openjdk7
. endif
.endif
+.if ${BOOTSTRAPJDKDIR} == ${LOCALBASE}/openjdk8
+CONFIGURE_ARGS+= --enable-sjavac
+.endif
+
# PR193009: work around the rtld bug
.if ${OSVERSION} < 1001511
CONFIGURE_ARGS+= --enable-static-libjli