aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-17 17:54:47 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-17 17:54:47 +0800
commitcc960a8b0822c786c4d3cf5e3068ea5ad91da891 (patch)
tree751aafd3de0da6a8bfe3e0417c48c1280a2a6aa4 /java
parenta69dfb8096d4b79ebcddccf3986e2a1257a6fd89 (diff)
downloadfreebsd-ports-gnome-cc960a8b0822c786c4d3cf5e3068ea5ad91da891.tar.gz
freebsd-ports-gnome-cc960a8b0822c786c4d3cf5e3068ea5ad91da891.tar.zst
freebsd-ports-gnome-cc960a8b0822c786c4d3cf5e3068ea5ad91da891.zip
Stagify.
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-sqlexplorer/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/java/eclipse-sqlexplorer/Makefile b/java/eclipse-sqlexplorer/Makefile
index 71254e414c6d..8b859b482635 100644
--- a/java/eclipse-sqlexplorer/Makefile
+++ b/java/eclipse-sqlexplorer/Makefile
@@ -20,14 +20,13 @@ USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
-NO_STAGE= yes
do-install:
- @${MKDIR} -p ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/plugins ${PREFIX}/lib/eclipse
- @(cd ${WRKSRC}; ${FIND} -s plugins -not -type d) \
- | ${SED} -ne 's,^,lib/eclipse/,p' >> ${TMPPLIST}
- @(cd ${WRKSRC}; ${FIND} -s -d plugins -type d) \
- | ${GREP} -vE '^plugins$$' \
- | ${SED} -ne 's,^,@dirrm lib/eclipse/,p' >> ${TMPPLIST}
+ @${MKDIR} -p ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/plugins ${STAGEDIR}${PREFIX}/lib/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s plugins -not -type d) \
+ | ${SED} -ne 's,^,lib/eclipse/,p' >> ${TMPPLIST}
+ @(cd ${WRKSRC}; ${FIND} -s -d plugins -type d) \
+ | ${GREP} -vE '^plugins$$' \
+ | ${SED} -ne 's,^,@dirrm lib/eclipse/,p' >> ${TMPPLIST}
.include <bsd.port.mk>