aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2019-10-04 04:35:29 +0800
committerjbeich <jbeich@FreeBSD.org>2019-10-04 04:35:29 +0800
commite791e4581e67889cde38a41a78df6bb9b6d19b0e (patch)
treeb325616b604b3f18f851e5b3104e0289676790a9 /java
parent80ba76a3fbeb0e57f6635bfc18af0e0a1907e61c (diff)
downloadfreebsd-ports-gnome-e791e4581e67889cde38a41a78df6bb9b6d19b0e.tar.gz
freebsd-ports-gnome-e791e4581e67889cde38a41a78df6bb9b6d19b0e.tar.zst
freebsd-ports-gnome-e791e4581e67889cde38a41a78df6bb9b6d19b0e.zip
devel/icu: update to 65.1
Changes: http://site.icu-project.org/download/65 ABI: https://abi-laboratory.pro/tracker/timeline/icu4c/
Diffstat (limited to 'java')
-rw-r--r--java/openjfx8-devel/Makefile2
-rw-r--r--java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_dom_Document.cpp42
2 files changed, 43 insertions, 1 deletions
diff --git a/java/openjfx8-devel/Makefile b/java/openjfx8-devel/Makefile
index 203b508235a8..323cf87e8297 100644
--- a/java/openjfx8-devel/Makefile
+++ b/java/openjfx8-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openjfx8
DISTVERSION= 8u202-b07
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= java x11-toolkits devel
MASTER_SITES= https://github.com/t6/openjfx/releases/download/release/ \
diff --git a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_dom_Document.cpp b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_dom_Document.cpp
new file mode 100644
index 000000000000..59340d13e632
--- /dev/null
+++ b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_dom_Document.cpp
@@ -0,0 +1,42 @@
+Regressed by https://github.com/unicode-org/icu/commit/480bec3ea652
+
+In file included from modules/web/build/bsd/Release/DerivedSources/WebCore/unified-sources/UnifiedSource220.cpp:4:
+modules/web/src/main/native/Source/WebCore/dom/Document.cpp:4707:39: error: expected ';' after do/while statement
+ U16_NEXT(characters, i, length, c)
+ ^
+ ;
+modules/web/src/main/native/Source/WebCore/dom/Document.cpp:4712:43: error: expected ';' after do/while statement
+ U16_NEXT(characters, i, length, c)
+ ^
+ ;
+modules/web/src/main/native/Source/WebCore/dom/Document.cpp:4772:46: error: expected ';' after do/while statement
+ U16_NEXT(qualifiedName, i, length, c)
+ ^
+ ;
+
+--- modules/web/src/main/native/Source/WebCore/dom/Document.cpp.orig 2018-12-10 16:30:22 UTC
++++ modules/web/src/main/native/Source/WebCore/dom/Document.cpp
+@@ -4704,12 +4704,12 @@ static bool isValidNameNonASCII(const UChar* character
+ unsigned i = 0;
+
+ UChar32 c;
+- U16_NEXT(characters, i, length, c)
++ U16_NEXT(characters, i, length, c);
+ if (!isValidNameStart(c))
+ return false;
+
+ while (i < length) {
+- U16_NEXT(characters, i, length, c)
++ U16_NEXT(characters, i, length, c);
+ if (!isValidNamePart(c))
+ return false;
+ }
+@@ -4769,7 +4769,7 @@ ExceptionOr<std::pair<AtomicString, AtomicString>> Doc
+
+ for (unsigned i = 0; i < length; ) {
+ UChar32 c;
+- U16_NEXT(qualifiedName, i, length, c)
++ U16_NEXT(qualifiedName, i, length, c);
+ if (c == ':') {
+ if (sawColon)
+ return Exception { InvalidCharacterError };