aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2019-03-30 01:06:20 +0800
committerglewis <glewis@FreeBSD.org>2019-03-30 01:06:20 +0800
commitef7964889dec2fab374d7f132be21dcada8c0970 (patch)
tree4891958af6f9af12e8db5da58db19180894864d2 /java
parent6396901a4f485cb77318584c672985a6c961e4c3 (diff)
downloadfreebsd-ports-gnome-ef7964889dec2fab374d7f132be21dcada8c0970.tar.gz
freebsd-ports-gnome-ef7964889dec2fab374d7f132be21dcada8c0970.tar.zst
freebsd-ports-gnome-ef7964889dec2fab374d7f132be21dcada8c0970.zip
Fix DTrace support for 32 bit platforms and re-enable it.
PR: 236876
Diffstat (limited to 'java')
-rw-r--r--java/openjdk11/Makefile4
-rw-r--r--java/openjdk11/files/patch-make_hotspot_lib_JvmDtraceObjects.gmk18
2 files changed, 18 insertions, 4 deletions
diff --git a/java/openjdk11/Makefile b/java/openjdk11/Makefile
index a7fd3dd0536c..aab32398480a 100644
--- a/java/openjdk11/Makefile
+++ b/java/openjdk11/Makefile
@@ -89,10 +89,6 @@ JDK_BUILD_TYPE= release
.include <bsd.port.pre.mk>
-.if ${ARCH} == i386
-CONFIGURE_ARGS+= --disable-dtrace
-.endif
-
BOOTSTRAP_JDKS= ${LOCALBASE}/openjdk11 \
${LOCALBASE}/bootstrap-openjdk11
diff --git a/java/openjdk11/files/patch-make_hotspot_lib_JvmDtraceObjects.gmk b/java/openjdk11/files/patch-make_hotspot_lib_JvmDtraceObjects.gmk
new file mode 100644
index 000000000000..a3bc5762dedb
--- /dev/null
+++ b/java/openjdk11/files/patch-make_hotspot_lib_JvmDtraceObjects.gmk
@@ -0,0 +1,18 @@
+--- make/hotspot/lib/JvmDtraceObjects.gmk
++++ make/hotspot/lib/JvmDtraceObjects.gmk
+@@ -201,8 +201,13 @@ ifeq ($(call check-jvm-feature, dtrace), true)
+ )
+ endif
+
+- DTRACE_FLAGS := -64 -G
+- DTRACE_CPP_FLAGS := -D_LP64 -x c
++ ifeq ($(OPENJDK_TARGET_CPU_BITS), 32)
++ DTRACE_FLAGS := -32 -G
++ DTRACE_CPP_FLAGS := -x c
++ else
++ DTRACE_FLAGS := -64 -G
++ DTRACE_CPP_FLAGS := -D_LP64 -x c
++ endif
+
+ # Make sure we run our selected compiler for preprocessing instead of letting
+ # the dtrace tool pick it on it's own.