aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-05-27 04:02:44 +0800
committerlinimon <linimon@FreeBSD.org>2017-05-27 04:02:44 +0800
commitf165f7743e2cbd42b86a4c6643b7648b0056c167 (patch)
tree0cde4b8b45b7e4393f92305c47df693c2ef646bd /java
parent2e8e012fe9faa77f49a5d468d23272c102a68d1d (diff)
downloadfreebsd-ports-gnome-f165f7743e2cbd42b86a4c6643b7648b0056c167.tar.gz
freebsd-ports-gnome-f165f7743e2cbd42b86a4c6643b7648b0056c167.tar.zst
freebsd-ports-gnome-f165f7743e2cbd42b86a4c6643b7648b0056c167.zip
Mark some ports failing on armv6, for errors classified as "???".
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'java')
-rw-r--r--java/java3d/Makefile2
-rw-r--r--java/jcommon/Makefile2
-rw-r--r--java/sigar/Makefile2
3 files changed, 6 insertions, 0 deletions
diff --git a/java/java3d/Makefile b/java/java3d/Makefile
index bc110f314f45..345db3ff069f 100644
--- a/java/java3d/Makefile
+++ b/java/java3d/Makefile
@@ -13,6 +13,8 @@ COMMENT= Provides API for creating and manipulation of 3D geometry
LICENSE= BSD2CLAUSE GPLv2
LICENSE_COMB= multi
+BROKEN_armv6= fails to compile: build.xml: Compile failed; see the compiler error output for details
+
USES= tar:bzip2
USE_JAVA= yes
USE_GL= gl
diff --git a/java/jcommon/Makefile b/java/jcommon/Makefile
index bf6d25277f8d..e87db7375f46 100644
--- a/java/jcommon/Makefile
+++ b/java/jcommon/Makefile
@@ -11,6 +11,8 @@ COMMENT= Collection of useful classes used by JFreeChart and JFreeReport
LICENSE= LGPL21
+BROKEN_armv6= fails to package: find: *: No such file or directory
+
USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
diff --git a/java/sigar/Makefile b/java/sigar/Makefile
index 200ae896c896..64011b3671b4 100644
--- a/java/sigar/Makefile
+++ b/java/sigar/Makefile
@@ -16,6 +16,8 @@ LICENSE_FILE= ${WRKSRC}/NOTICE
BUILD_DEPENDS= ${ANT_CMD}:devel/apache-ant
LIB_DEPENDS= libsigar.so:devel/sigar
+BROKEN_armv6= fails to compile: jni-build.xml: gcc failed with return code 1
+
USE_GITHUB= yes
GH_ACCOUNT= amishHammer
GH_TAGNAME= b5af695