aboutsummaryrefslogtreecommitdiffstats
path: root/korean/nabi
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2003-09-19 12:45:21 +0800
committerperky <perky@FreeBSD.org>2003-09-19 12:45:21 +0800
commitdfa0105e13c23954326971f7b7a7432728ec7a9b (patch)
treebcc25f9830de7e8e47045bd624d827a9870f26e5 /korean/nabi
parent6fb75176a7d192af6543cf687ebccedf551d9829 (diff)
downloadfreebsd-ports-gnome-dfa0105e13c23954326971f7b7a7432728ec7a9b.tar.gz
freebsd-ports-gnome-dfa0105e13c23954326971f7b7a7432728ec7a9b.tar.zst
freebsd-ports-gnome-dfa0105e13c23954326971f7b7a7432728ec7a9b.zip
Add a workaround to avoid a fatal confliction with qt32.
Reviewed by: Choe Hwanjin <krisna@kldp.org> (author) Approved by: portmgr (will)
Diffstat (limited to 'korean/nabi')
-rw-r--r--korean/nabi/Makefile1
-rw-r--r--korean/nabi/files/patch-src_ic.c20
2 files changed, 21 insertions, 0 deletions
diff --git a/korean/nabi/Makefile b/korean/nabi/Makefile
index 642ea5f2d47a..0d243286e58d 100644
--- a/korean/nabi/Makefile
+++ b/korean/nabi/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nabi
PORTVERSION= 0.4
+PORTREVISION= 1
CATEGORIES= korean gnome x11
MASTER_SITES= http://download.kldp.net/nabi/
diff --git a/korean/nabi/files/patch-src_ic.c b/korean/nabi/files/patch-src_ic.c
new file mode 100644
index 000000000000..59a186bee04a
--- /dev/null
+++ b/korean/nabi/files/patch-src_ic.c
@@ -0,0 +1,20 @@
+--- src/ic.c.orig Sat Aug 23 14:15:05 2003
++++ src/ic.c Fri Sep 19 10:47:55 2003
+@@ -1219,7 +1219,7 @@
+ * befor commiting the string. but it makes too many flickering
+ * so I first send commit string and then delete preedit string.
+ * This makes some problem on gtk2 entry */
+- /* nabi_ic_preedit_clear(ic); */
++ nabi_ic_preedit_clear(ic);
+
+ list[0] = buf;
+ ret = XwcTextListToTextProperty(server->display, list, 1,
+@@ -1237,7 +1237,7 @@
+ XFree(tp.value);
+
+ /* we delete preedit string here */
+- nabi_ic_preedit_clear(ic);
++ /* nabi_ic_preedit_clear(ic); */
+
+ return True;
+ }