aboutsummaryrefslogtreecommitdiffstats
path: root/korean
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2011-03-17 18:19:17 +0800
committerpav <pav@FreeBSD.org>2011-03-17 18:19:17 +0800
commit4e7dc0bf2cc23dbb1b6a6495c981c92179dddcf4 (patch)
tree1768a6cb5166f96c9d168cf7476277fa6ac03bbd /korean
parent4b19deb23d1d64cb4bfe2d21cbcf938802280eb7 (diff)
downloadfreebsd-ports-gnome-4e7dc0bf2cc23dbb1b6a6495c981c92179dddcf4.tar.gz
freebsd-ports-gnome-4e7dc0bf2cc23dbb1b6a6495c981c92179dddcf4.tar.zst
freebsd-ports-gnome-4e7dc0bf2cc23dbb1b6a6495c981c92179dddcf4.zip
- Unbreak
PR: ports/154793 Submitted by: Takefu <takefu@airport.fm>
Diffstat (limited to 'korean')
-rw-r--r--korean/unzip/Makefile2
-rw-r--r--korean/unzip/files/patch-unzip.c40
2 files changed, 20 insertions, 22 deletions
diff --git a/korean/unzip/Makefile b/korean/unzip/Makefile
index 044113cfd169..159ffa012685 100644
--- a/korean/unzip/Makefile
+++ b/korean/unzip/Makefile
@@ -14,6 +14,4 @@ CONFLICTS= unzip-[0-9]* ru-unzip-[0-9]* zh-unzip-[0-9]*
EXTRA_PATCHES= ${.CURDIR}/files/patch-*
MASTERDIR= ${.CURDIR}/../../archivers/unzip
-BROKEN= does not patch
-
.include "${MASTERDIR}/Makefile"
diff --git a/korean/unzip/files/patch-unzip.c b/korean/unzip/files/patch-unzip.c
index 02f9df5624d2..7e8b3245074c 100644
--- a/korean/unzip/files/patch-unzip.c
+++ b/korean/unzip/files/patch-unzip.c
@@ -1,25 +1,25 @@
---- unzip.c.orig Sun Jan 27 11:26:16 2002
-+++ unzip.c Wed May 21 03:42:30 2003
-@@ -595,7 +595,8 @@
- -o overwrite files WITHOUT prompting -aa treat ALL files as text\n \
- -j junk paths (do not make directories) -v be verbose/print version info\n\
- %c-C%c match filenames case-insensitively %c-L%c make (some) names \
--lowercase\n %-42s %c-V%c retain VMS version numbers\n%s";
-+lowercase\n %-42s %c-V%c retain VMS version numbers\n\
+--- unzip.c.orig 2009-04-17 03:26:52.000000000 +0900
++++ unzip.c 2011-02-15 11:25:36.000000000 +0900
+@@ -664,7 +664,8 @@
+ -j junk paths (do not make directories) -aa treat ALL files as text\n\
+ -U use escapes for all non-ASCII Unicode -UU ignore any Unicode fields\n\
+ -C match filenames case-insensitively -L make (some) names \
+-lowercase\n %-42s -V retain VMS version numbers\n%s";
++lowercase\n %-42s -V retain VMS version numbers\n\
+ -. don't translate filenames\n%s";
-
- static ZCONST char Far UnzipUsageLine5[] = "\
- Examples (see unzip.txt for more info):\n\
-@@ -1476,6 +1477,12 @@
- ++uO.ddotflag;
+ #else /* !VMS */
+ static ZCONST char Far UnzipUsageLine4[] = "\
+ modifiers:\n\
+@@ -1829,6 +1830,12 @@
+ ++uO.cflxflag;
break;
- #endif /* !RISCOS && !CMS_MVS && !TANDEM */
-+ case ('.'):
-+ if (negative)
-+ uO.dotflag = FALSE, negative = 0;
-+ else
-+ uO.dotflag = TRUE;
-+ break;
+ #endif /* UNIX */
++ case ('.'):
++ if (negative)
++ uO.dotflag = FALSE, negative = 0;
++ else
++ uO.dotflag = TRUE;
++ break;
default:
error = TRUE;
break;