aboutsummaryrefslogtreecommitdiffstats
path: root/korean
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-03-20 23:45:21 +0800
committermiwi <miwi@FreeBSD.org>2010-03-20 23:45:21 +0800
commit989d45aca7f2fb143f11173522425549098534c0 (patch)
tree6493e90787bddb6b1fbaad53820f6eb15bd1969b /korean
parent3122cf905935ae8e575bf7be5042484f1e0a4107 (diff)
downloadfreebsd-ports-gnome-989d45aca7f2fb143f11173522425549098534c0.tar.gz
freebsd-ports-gnome-989d45aca7f2fb143f11173522425549098534c0.tar.zst
freebsd-ports-gnome-989d45aca7f2fb143f11173522425549098534c0.zip
- Mark BROKEN on HEAD: fails to build with new utmpx
Reported by: pointyhat
Diffstat (limited to 'korean')
-rw-r--r--korean/eterm/Makefile8
-rw-r--r--korean/gtkcomm/Makefile8
-rw-r--r--korean/hanterm/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/korean/eterm/Makefile b/korean/eterm/Makefile
index ce50fa3b5e45..461469597a59 100644
--- a/korean/eterm/Makefile
+++ b/korean/eterm/Makefile
@@ -29,6 +29,12 @@ CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" LOCALBASE="${LOCALBASE}"
MAN1= Eterm.1
MAKE_JOBS_UNSAFE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
pre-patch:
@${PERL} -pi -e 's,<malloc.h>,<stdlib.h>,' \
${WRKSRC}/libmej/debug.c ${WRKSRC}/libmej/strings.c
@@ -45,4 +51,4 @@ post-install:
${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/korean/gtkcomm/Makefile b/korean/gtkcomm/Makefile
index 66d6108c8608..49d9f122550a 100644
--- a/korean/gtkcomm/Makefile
+++ b/korean/gtkcomm/Makefile
@@ -20,8 +20,14 @@ USE_PERL5_BUILD=yes
USE_GNOME= imlib
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
pre-patch:
@${PERL} -pi -e 's^-l(pthread|c_r)^${PTHREAD_LIBS}^g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/korean/hanterm/Makefile b/korean/hanterm/Makefile
index 7549a0edef6b..343ba7a83150 100644
--- a/korean/hanterm/Makefile
+++ b/korean/hanterm/Makefile
@@ -23,6 +23,12 @@ USE_XORG= ice sm x11 xaw xext xmu xpm xt
NO_INSTALL_MANPAGES= yes
ALL_TARGET= hanterm
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hanterm ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/Hanterm.ad \
@@ -33,4 +39,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>