aboutsummaryrefslogtreecommitdiffstats
path: root/lang/Makefile
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2011-05-19 21:54:39 +0800
committerkuriyama <kuriyama@FreeBSD.org>2011-05-19 21:54:39 +0800
commit356a148b77654584a2c7e044896f43788f64e0b9 (patch)
tree0264ecd8a014f3d0b327149b4840328ecc1080c6 /lang/Makefile
parentf5f12e36f411519d36819b0f865889b7713f563e (diff)
downloadfreebsd-ports-gnome-356a148b77654584a2c7e044896f43788f64e0b9.tar.gz
freebsd-ports-gnome-356a148b77654584a2c7e044896f43788f64e0b9.tar.zst
freebsd-ports-gnome-356a148b77654584a2c7e044896f43788f64e0b9.zip
There are a lot of XSS, a security hole typically found in web
applications, caused by incorrect (or lack of) JavaScript escaping. This module is aimed to provide a secure JavaScript escaping to avoid XSS with JavaScript values. The escaping routine JavaScript::Value::Escape provides escapes q!"!, q!'!, q!&!, q!=!, q!-!, q!+!, q!;!, q!<!, q!>!, q!/!, q!\! and control characters to JavaScript unicode entities like "\u0026". WWW: http://search.cpan.org/dist/JavaScript-Value-Escape/
Diffstat (limited to 'lang/Makefile')
-rw-r--r--lang/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 64af218e3bb3..08a96db0cba7 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -213,6 +213,7 @@
SUBDIR += p5-JavaScript
SUBDIR += p5-JavaScript-SpiderMonkey
SUBDIR += p5-JavaScript-Squish
+ SUBDIR += p5-JavaScript-Value-Escape
SUBDIR += p5-List-MoreUtils
SUBDIR += p5-Modern-Perl
SUBDIR += p5-Parse-Perl