aboutsummaryrefslogtreecommitdiffstats
path: root/lang/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-11-24 17:33:54 +0800
committermiwi <miwi@FreeBSD.org>2008-11-24 17:33:54 +0800
commit61d12faf4702685388d27cd8ff442523ad5821c5 (patch)
tree473dc76ef0c8cba3e5630c1770a42964b732cf21 /lang/Makefile
parent0cc95493219da215ba5238d677d632f2603f26ab (diff)
downloadfreebsd-ports-gnome-61d12faf4702685388d27cd8ff442523ad5821c5.tar.gz
freebsd-ports-gnome-61d12faf4702685388d27cd8ff442523ad5821c5.tar.zst
freebsd-ports-gnome-61d12faf4702685388d27cd8ff442523ad5821c5.zip
cparser is a C compiler, which can parse C89 and C99 as well as many GCC and
some MSVC extensions. It also provides many useful analyses for warnings. It uses libFIRM, which provides a SSA-based intermediate representation in form of explicit dependency graphs, for optimization and code generation. Parsing is done with a handwritten recursive descent parser. The AST representation is straightforward, so it can be used for other purposes than code generation. * fast recursive descent parser, parses C89 and C99 * handles most GCC extensions, f.e. __attribute__, inline assembler, computed goto, statement expressions * handles some MSVC extensions (like declspec) * provides many useful warnings * format string checker for char and wchar_t * unreachable code analysis * missing return statement check, which pinpoints exact location(s) * write-only/-self variables detection * missing and redundant forward declarations * most warnings switches, which are available for GCC * provides concise messages in case of error, for example when encountering misspelled typenames * compiler driver compatible with with GCC (-fxxx, -Wxxx, -M, ...) * uses libFIRM for optimization and code generation (devel/libfirm) WWW: http://www.libfirm.org Submitted by: Christoph Mallon <christoph.mallon at gmx.de>
Diffstat (limited to 'lang/Makefile')
-rw-r--r--lang/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 3f6e6c4c282d..4919612ff0ab 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -33,6 +33,7 @@
SUBDIR += cmucl-extra
SUBDIR += cocor
SUBDIR += compaq-cc
+ SUBDIR += cparser
SUBDIR += csharp-mode.el
SUBDIR += cu-prolog
SUBDIR += cython