aboutsummaryrefslogtreecommitdiffstats
path: root/lang/adacontrol/Makefile
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-03-14 16:36:33 +0800
committermarino <marino@FreeBSD.org>2014-03-14 16:36:33 +0800
commit51c34344ffdde0cbf12bad971c43049a9d3287f5 (patch)
tree4917a8fc3e5ca77923bab6500f3286c0a4cdb703 /lang/adacontrol/Makefile
parent92bb0c7790736795c164e50292192e898ff3e47f (diff)
downloadfreebsd-ports-gnome-51c34344ffdde0cbf12bad971c43049a9d3287f5.tar.gz
freebsd-ports-gnome-51c34344ffdde0cbf12bad971c43049a9d3287f5.tar.zst
freebsd-ports-gnome-51c34344ffdde0cbf12bad971c43049a9d3287f5.zip
lang/adacontrol: Reaction to gcc-aux upgrade to gcc49
While the version remains the same, AdaControl comes with two flavors of distfiles: "old" and "new". The "old" distfile was appropriate for gcc47-aux, but the "new" one is required for the gcc49-based ada compiler. This change updates the distfile to be used to build adacontrol.
Diffstat (limited to 'lang/adacontrol/Makefile')
-rw-r--r--lang/adacontrol/Makefile32
1 files changed, 21 insertions, 11 deletions
diff --git a/lang/adacontrol/Makefile b/lang/adacontrol/Makefile
index 996e210c8cb6..1965d7e60c6d 100644
--- a/lang/adacontrol/Makefile
+++ b/lang/adacontrol/Makefile
@@ -3,10 +3,10 @@
PORTNAME= adacontrol
PORTVERSION= 1.15r5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= SF/adacontrol
-DISTNAME= adactl_old-${PORTVERSION}-src
+DISTNAME= adactl-${PORTVERSION}-src
EXTRACT_SUFX= .tgz
MAINTAINER= marino@FreeBSD.org
@@ -17,26 +17,36 @@ LICENSE_COMB= multi
BUILD_DEPENDS= asis>=2011:${PORTSDIR}/lang/asis
-USES= ada gmake
+USES= ada
WRKSRC= ${WRKDIR}/adactl-${PORTVERSION}
BUILD_WRKSRC= ${WRKSRC}/src
ALL_TARGET= build
+PORTDOCS= adacontrol*
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+do-build:
+ (cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} gnatmake -Pbuild)
do-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/bin
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/gps/plug-ins
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/gps/html
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/adacontrol
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/gprconfig
+ ${MKDIR} ${STAGEDIR}${PREFIX}/bin \
+ ${STAGEDIR}${PREFIX}/share/gps/plug-ins \
+ ${STAGEDIR}${PREFIX}/share/doc/gps/html \
+ ${STAGEDIR}${PREFIX}/share/gprconfig
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/adactl ${BUILD_WRKSRC}/pfni \
${BUILD_WRKSRC}/ptree ${STAGEDIR}/${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/GPS/adacontrol.xml \
${STAGEDIR}${PREFIX}/share/gprconfig
${INSTALL_DATA} ${WRKSRC}/GPS/*adactl* ${WRKSRC}/GPS/pfni.* \
${STAGEDIR}${PREFIX}/share/gps/plug-ins
- ${INSTALL_MAN} ${WRKSRC}/doc/*.html \
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html \
${STAGEDIR}${PREFIX}/share/doc/gps/html
- ${INSTALL_MAN} ${WRKSRC}/doc/*.pdf ${WRKSRC}/doc/*.html \
- ${STAGEDIR}${PREFIX}/share/doc/adacontrol
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.pdf ${WRKSRC}/doc/*.html \
+ ${STAGEDIR}${DOCSDIR}
+.endif
.include <bsd.port.mk>