aboutsummaryrefslogtreecommitdiffstats
path: root/lang/adacontrol
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-03-14 16:36:33 +0800
committerJohn Marino <marino@FreeBSD.org>2014-03-14 16:36:33 +0800
commit619e18e8ef06c17e9d0535c33a880efdcbd93bec (patch)
tree4917a8fc3e5ca77923bab6500f3286c0a4cdb703 /lang/adacontrol
parentbc7ac57a743832bebd6e2bc53ea1ef0fc2027272 (diff)
downloadfreebsd-ports-gnome-619e18e8ef06c17e9d0535c33a880efdcbd93bec.tar.gz
freebsd-ports-gnome-619e18e8ef06c17e9d0535c33a880efdcbd93bec.tar.zst
freebsd-ports-gnome-619e18e8ef06c17e9d0535c33a880efdcbd93bec.zip
lang/adacontrol: Reaction to gcc-aux upgrade to gcc49
While the version remains the same, AdaControl comes with two flavors of distfiles: "old" and "new". The "old" distfile was appropriate for gcc47-aux, but the "new" one is required for the gcc49-based ada compiler. This change updates the distfile to be used to build adacontrol.
Diffstat (limited to 'lang/adacontrol')
-rw-r--r--lang/adacontrol/Makefile32
-rw-r--r--lang/adacontrol/distinfo4
-rw-r--r--lang/adacontrol/files/patch-src_Makefile32
-rw-r--r--lang/adacontrol/pkg-plist5
4 files changed, 23 insertions, 50 deletions
diff --git a/lang/adacontrol/Makefile b/lang/adacontrol/Makefile
index 996e210c8cb6..1965d7e60c6d 100644
--- a/lang/adacontrol/Makefile
+++ b/lang/adacontrol/Makefile
@@ -3,10 +3,10 @@
PORTNAME= adacontrol
PORTVERSION= 1.15r5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= SF/adacontrol
-DISTNAME= adactl_old-${PORTVERSION}-src
+DISTNAME= adactl-${PORTVERSION}-src
EXTRACT_SUFX= .tgz
MAINTAINER= marino@FreeBSD.org
@@ -17,26 +17,36 @@ LICENSE_COMB= multi
BUILD_DEPENDS= asis>=2011:${PORTSDIR}/lang/asis
-USES= ada gmake
+USES= ada
WRKSRC= ${WRKDIR}/adactl-${PORTVERSION}
BUILD_WRKSRC= ${WRKSRC}/src
ALL_TARGET= build
+PORTDOCS= adacontrol*
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+do-build:
+ (cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} gnatmake -Pbuild)
do-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/bin
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/gps/plug-ins
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/gps/html
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/adacontrol
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/gprconfig
+ ${MKDIR} ${STAGEDIR}${PREFIX}/bin \
+ ${STAGEDIR}${PREFIX}/share/gps/plug-ins \
+ ${STAGEDIR}${PREFIX}/share/doc/gps/html \
+ ${STAGEDIR}${PREFIX}/share/gprconfig
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/adactl ${BUILD_WRKSRC}/pfni \
${BUILD_WRKSRC}/ptree ${STAGEDIR}/${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/GPS/adacontrol.xml \
${STAGEDIR}${PREFIX}/share/gprconfig
${INSTALL_DATA} ${WRKSRC}/GPS/*adactl* ${WRKSRC}/GPS/pfni.* \
${STAGEDIR}${PREFIX}/share/gps/plug-ins
- ${INSTALL_MAN} ${WRKSRC}/doc/*.html \
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html \
${STAGEDIR}${PREFIX}/share/doc/gps/html
- ${INSTALL_MAN} ${WRKSRC}/doc/*.pdf ${WRKSRC}/doc/*.html \
- ${STAGEDIR}${PREFIX}/share/doc/adacontrol
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.pdf ${WRKSRC}/doc/*.html \
+ ${STAGEDIR}${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/lang/adacontrol/distinfo b/lang/adacontrol/distinfo
index 0ffff3f097eb..ea450e90f81c 100644
--- a/lang/adacontrol/distinfo
+++ b/lang/adacontrol/distinfo
@@ -1,2 +1,2 @@
-SHA256 (adactl_old-1.15r5-src.tgz) = 0d495ee1f6c643c807f295474f32726c5935c5ec8a94c847c25e803b1546f4fb
-SIZE (adactl_old-1.15r5-src.tgz) = 1700731
+SHA256 (adactl-1.15r5-src.tgz) = e3e3029ad5b7ad941bff64eafe2566ec3f7815af8e03066cbb4cd87235023e4e
+SIZE (adactl-1.15r5-src.tgz) = 1707819
diff --git a/lang/adacontrol/files/patch-src_Makefile b/lang/adacontrol/files/patch-src_Makefile
deleted file mode 100644
index e5796c9060c4..000000000000
--- a/lang/adacontrol/files/patch-src_Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
---- src/Makefile.orig 2013-07-09 13:33:01.000000000 +0000
-+++ src/Makefile
-@@ -2,7 +2,7 @@
- # Set PATH to ASIS library below (default corresponds to the case where you
- # installed ASIS in the Gnat directory)
-
--ASIS_TOP = /usr/gnat/
-+ASIS_TOP = ${PREFIX}
-
- ###############################################################################
- # Depending on your version of ASIS, the ASIS directory may be split into
-@@ -22,6 +22,10 @@ ASIS_INCLUDE = ${ASIS_TOP}/include/asis
- ASIS_OBJ = ${ASIS_TOP}/lib/asis
- ASIS_LIB = ${ASIS_TOP}/lib/asis
-
-+GU_INCLUDE = ${ASIS_TOP}/include/gnat_util
-+GU_OBJ = ${ASIS_TOP}/lib/gnat_util
-+GU_LIB = ${ASIS_TOP}/lib/gnat_util
-+
- ###############################################################################
- # SYSTEM COMMANDS (do not change)
-
-@@ -48,7 +52,8 @@ EXT = ${UNIX_EXT}
- GARGS = -gnatf -gnatwa -aI${ASIS_INCLUDE} -aO${ASIS_OBJ} -g
- CARGS = -cargs -O2 -gnatWh -gnat05 -gnato
- BARGS = -bargs -E
--LARGS = -largs -L${ASIS_LIB} -lasis
-+LARGS = -largs -L${ASIS_LIB} -lasis -L${GU_LIB} -lgnat_util
-+GARGS+= -aI${GU_INCLUDE} -aO${GU_OBJ}
-
- # Uncomment the following line if you are running GnatPro 6.1.2 or above
- #CARGS_EXTRA = ${CARGS} -fno-tree-vrp
diff --git a/lang/adacontrol/pkg-plist b/lang/adacontrol/pkg-plist
index cd9cd49a40a8..34f64a23b11f 100644
--- a/lang/adacontrol/pkg-plist
+++ b/lang/adacontrol/pkg-plist
@@ -1,10 +1,6 @@
bin/adactl
bin/pfni
bin/ptree
-%%DOCSDIR%%/adacontrol_pm.html
-%%DOCSDIR%%/adacontrol_pm.pdf
-%%DOCSDIR%%/adacontrol_ug.html
-%%DOCSDIR%%/adacontrol_ug.pdf
share/doc/gps/html/adacontrol_pm.html
share/doc/gps/html/adacontrol_ug.html
share/gprconfig/adacontrol.xml
@@ -14,7 +10,6 @@ share/gps/plug-ins/adactl_ask.gif
share/gps/plug-ins/pfni.py
share/gps/plug-ins/pfni.xml
share/gps/plug-ins/zadactl.xml
-@dirrm %%DOCSDIR%%
@dirrmtry share/doc/gps/html
@dirrmtry share/doc/gps
@dirrmtry share/doc