aboutsummaryrefslogtreecommitdiffstats
path: root/lang/bas2tap
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-09-24 21:30:45 +0800
committerrene <rene@FreeBSD.org>2013-09-24 21:30:45 +0800
commit81c0db28664398fa5b47d1650843d35ccb07141c (patch)
tree63b91c14c18ef3ff351ad39ff2d605f26f365e2a /lang/bas2tap
parent2bb11ea88dee22b92ef42c7a52c40c4b7047793f (diff)
downloadfreebsd-ports-gnome-81c0db28664398fa5b47d1650843d35ccb07141c.tar.gz
freebsd-ports-gnome-81c0db28664398fa5b47d1650843d35ccb07141c.tar.zst
freebsd-ports-gnome-81c0db28664398fa5b47d1650843d35ccb07141c.zip
Add staging support.
Diffstat (limited to 'lang/bas2tap')
-rw-r--r--lang/bas2tap/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/lang/bas2tap/Makefile b/lang/bas2tap/Makefile
index 315b687d7ac0..d956386e1c2b 100644
--- a/lang/bas2tap/Makefile
+++ b/lang/bas2tap/Makefile
@@ -20,18 +20,17 @@ PLIST_FILES= bin/${PORTNAME}
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
do-build:
${CC} ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME} -lm ${CFLAGS}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
.endif