aboutsummaryrefslogtreecommitdiffstats
path: root/lang/cli
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-04-10 06:38:40 +0800
committersobomax <sobomax@FreeBSD.org>2002-04-10 06:38:40 +0800
commit8ec882a742e51e1fb168ea5b84024e3e954100d4 (patch)
tree74a1d929e2fb6b07f9ac63cc0aaa6aff1b3a09b1 /lang/cli
parent4cc8f40fd6d3ff5d1cea3758d380754fe81bcd3b (diff)
downloadfreebsd-ports-gnome-8ec882a742e51e1fb168ea5b84024e3e954100d4.tar.gz
freebsd-ports-gnome-8ec882a742e51e1fb168ea5b84024e3e954100d4.tar.zst
freebsd-ports-gnome-8ec882a742e51e1fb168ea5b84024e3e954100d4.zip
Fix a silly permission bug, which results in a 777 permission all over the
WRKSRC. The problem was that when trying to map read-only FAT attribute into *nix permission, MS assumed that if that attribute isn't set then write permissions should be granted to everyone. Funny, eh? Bump PORTREVISION.
Diffstat (limited to 'lang/cli')
-rw-r--r--lang/cli/Makefile3
-rw-r--r--lang/cli/files/patch-pal::unix::file::file.c25
2 files changed, 26 insertions, 2 deletions
diff --git a/lang/cli/Makefile b/lang/cli/Makefile
index fdc0878fc835..7054d4aa10f0 100644
--- a/lang/cli/Makefile
+++ b/lang/cli/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cli
PORTVERSION= 20020326
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= http://download.microsoft.com/download/.netframesdk/CLI/Beta1/WXP/EN-US/ \
http://download.microsoft.com/download/.netframesdk/Beta1/WXP/EN-US/ \
@@ -43,7 +43,6 @@ post-configure:
done
do-build:
- @${CHMOD} 700 ${WRKSRC} # <- we need this because build system creates world-writeable dirs
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${SH} env.sh ./buildall)
.if !defined(I_AGREE_TO_LICENSE_TERMS)
diff --git a/lang/cli/files/patch-pal::unix::file::file.c b/lang/cli/files/patch-pal::unix::file::file.c
new file mode 100644
index 000000000000..67013da52e2b
--- /dev/null
+++ b/lang/cli/files/patch-pal::unix::file::file.c
@@ -0,0 +1,25 @@
+
+$FreeBSD$
+
+--- pal/unix/file/file.c 2002/04/09 22:17:33 1.1
++++ pal/unix/file/file.c 2002/04/09 22:19:43
+@@ -2822,18 +2822,10 @@
+ }
+ else
+ {
+- /* give write permission to anyone that has read permission */
++ /* give write permission to owner if it has read permission */
+ if ( new_mode & S_IRUSR )
+ {
+ new_mode |= S_IWUSR;
+- }
+- if ( new_mode & S_IRGRP )
+- {
+- new_mode |= S_IWGRP;
+- }
+- if ( new_mode & S_IROTH )
+- {
+- new_mode |= S_IWOTH;
+ }
+ }
+ TRACE("new mode is 0x%lx\n", new_mode);