aboutsummaryrefslogtreecommitdiffstats
path: root/lang/clisp/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-11-28 02:21:12 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-11-28 02:21:12 +0800
commite0fea2876386c3ed48804ee9e750a338d4a1460b (patch)
treeb91c21b3e99fa82e54d69a6296a5c0281b1fef73 /lang/clisp/Makefile
parent3878672a4a6a5d9c9be39d97af7babb1df644854 (diff)
downloadfreebsd-ports-gnome-e0fea2876386c3ed48804ee9e750a338d4a1460b.tar.gz
freebsd-ports-gnome-e0fea2876386c3ed48804ee9e750a338d4a1460b.tar.zst
freebsd-ports-gnome-e0fea2876386c3ed48804ee9e750a338d4a1460b.zip
- Add D-Bus and threads support
PR: 140504 Submitted by: "Joseph S. Atkinson" <jsa@wickedmachine.net>
Diffstat (limited to 'lang/clisp/Makefile')
-rw-r--r--lang/clisp/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/lang/clisp/Makefile b/lang/clisp/Makefile
index 7170d60f3511..e56d27594407 100644
--- a/lang/clisp/Makefile
+++ b/lang/clisp/Makefile
@@ -37,6 +37,7 @@ MAKE_JOBS_UNSAFE=yes
OPTIONS= BDB "Build Berkeley Database module" off \
CLX_MIT "Build X11 module (original MIT version)" off \
CLX_NEW "Build X11 module (new faster version)" off \
+ DBUS "D-BUS control module" Off \
FASTCGI "Build FastCGI module" off \
GDBM "Build GNU Database manager module" off \
GTK2 "Build Gtk+2 module" off \
@@ -46,6 +47,7 @@ OPTIONS= BDB "Build Berkeley Database module" off \
PGSQL "Build PostgreSQL database module" off \
RAWSOCK "Build Raw Socket Access module" on \
SVM "Enable Support Vector Machines module" off \
+ THREADS "Enable multithreaded (Experimental)" Off \
WILDCARD "Build wildcard matching module" on \
ZLIB "Build ZLib interface module " off
@@ -59,8 +61,8 @@ SUB_FILES= pkg-message
CONFIGURE_ARGS+=--disable-mmap
.endif
-MODULES= BDB CLX_MIT CLX_NEW FASTCGI GDBM GTK2 ORACLE PARI PCRE PGSQL \
- RAWSOCK SVM WILDCARD ZLIB
+MODULES= BDB CLX_MIT CLX_NEW DBUS FASTCGI GDBM GTK2 ORACLE PARI PCRE \
+ PGSQL RAWSOCK SVM WILDCARD ZLIB
.for mod in ${MODULES}
. if defined(WITH_${mod})
@@ -98,6 +100,11 @@ CONFIGURE_ARGS+=--with-module=clx/mit-clx
CONFIGURE_ARGS+=--with-module=clx/new-clx
.endif
+.if defined(WITH_DBUS)
+LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
+CONFIGURE_ARGS+=--with-module=dbus
+.endif
+
.if defined(WITH_FASTCGI)
LIB_DEPENDS+= fcgi.0:${PORTSDIR}/www/fcgi
CONFIGURE_ARGS+=--with-module=fastcgi
@@ -145,6 +152,12 @@ RUN_DEPENDS+= svm-predict:${PORTSDIR}/science/libsvm
CONFIGURE_ARGS+=--with-module=libsvm
.endif
+.if defined(WITH_THREADS)
+CONFIGURE_ARGS+= --with-threads=POSIX_THREADS \
+ LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
+PKGNAMESUFFIX= -threaded
+.endif
+
.if defined(WITH_WILDCARD)
CONFIGURE_ARGS+=--with-module=wildcard
.endif