aboutsummaryrefslogtreecommitdiffstats
path: root/lang/clojure
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-03-22 03:13:29 +0800
committermadpilot <madpilot@FreeBSD.org>2013-03-22 03:13:29 +0800
commit8612b8f88e8da80498006ea5180b49280a322677 (patch)
tree99107ea7e535336bf2c71f87b2fb665641bbd9b8 /lang/clojure
parent956ce0bbae4ae8ab4e24d962d1b61458888ac35f (diff)
downloadfreebsd-ports-gnome-8612b8f88e8da80498006ea5180b49280a322677.tar.gz
freebsd-ports-gnome-8612b8f88e8da80498006ea5180b49280a322677.tar.zst
freebsd-ports-gnome-8612b8f88e8da80498006ea5180b49280a322677.zip
- Update to 1.5.1
- Remove indeterminate article from COMMENT - Convert to new options framework PR: ports/177121 Submitted by: Jens Jahnke <jan0sch@gmx.net> (maintainer)
Diffstat (limited to 'lang/clojure')
-rw-r--r--lang/clojure/Makefile15
-rw-r--r--lang/clojure/distinfo4
2 files changed, 11 insertions, 8 deletions
diff --git a/lang/clojure/Makefile b/lang/clojure/Makefile
index 6407861d7105..c8b137120ea5 100644
--- a/lang/clojure/Makefile
+++ b/lang/clojure/Makefile
@@ -2,27 +2,30 @@
# $FreeBSD$
PORTNAME= clojure
-PORTVERSION= 1.5.0
+PORTVERSION= 1.5.1
PORTEPOCH= 2
CATEGORIES= lang lisp java
MASTER_SITES= http://repo1.maven.org/maven2/org/clojure/clojure/${PORTVERSION}/
MAINTAINER= jan0sch@gmx.net
-COMMENT= A dynamic programming language for the JVM
+COMMENT= Dynamic programming language for the JVM
USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
NO_BUILD= yes
SUB_FILES= clojure-bin
-OPTIONS= JLINE "Enable jline support for the REPL" on
+
+OPTIONS_DEFINE= JLINE
+OPTIONS_DEFAULT= JLINE
+JLINE_DESC= jline support for the REPL
PLIST_FILES= bin/clojure \
%%JAVAJARDIR%%/clojure.jar
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.ifdef(WITH_JLINE)
+.if ${PORT_OPTIONS:MJLINE}
RUN_DEPENDS+= jline>=0.9.91:${PORTSDIR}/devel/jline
CLOJURE_JLINE_RUNNER=jline.ConsoleRunner
.endif
@@ -33,4 +36,4 @@ do-install:
@${INSTALL_SCRIPT} ${WRKDIR}/clojure-bin ${PREFIX}/bin/clojure
@${INSTALL_DATA} ${WRKSRC}/clojure-${PORTVERSION}.jar ${JAVAJARDIR}/clojure.jar
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/clojure/distinfo b/lang/clojure/distinfo
index 1647e01cfebc..98a02927613d 100644
--- a/lang/clojure/distinfo
+++ b/lang/clojure/distinfo
@@ -1,2 +1,2 @@
-SHA256 (clojure-1.5.0.zip) = 27227a196de0d36732b746917d49ed6ba76ad966e28bdb493ca55d862866f408
-SIZE (clojure-1.5.0.zip) = 4791197
+SHA256 (clojure-1.5.1.zip) = fe7b32ca36c1a5451fe6fe0ea8ad25f7bc04beeb63e171e10464efd64c94f1e1
+SIZE (clojure-1.5.1.zip) = 4783378