aboutsummaryrefslogtreecommitdiffstats
path: root/lang/cython
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
committermat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
commit32512cab3e8dd90b7cd0525bb5dc98007db431e2 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /lang/cython
parentb4ddc365e88ebdb48627086b02365b74119cf189 (diff)
downloadfreebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.gz
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.zst
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Diffstat (limited to 'lang/cython')
-rw-r--r--lang/cython/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/cython/Makefile b/lang/cython/Makefile
index 95bafc0af125..9faed36fff74 100644
--- a/lang/cython/Makefile
+++ b/lang/cython/Makefile
@@ -6,6 +6,7 @@ PORTVERSION= 0.26
CATEGORIES= lang python
MASTER_SITES= http://www.cython.org/release/ \
CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= Cython-${PORTVERSION}
MAINTAINER= vmagerya@gmail.com
@@ -14,8 +15,9 @@ COMMENT= Compiler for Writing C Extensions for the Python Language
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES?= python
-USE_PYTHON+= autoplist distutils
+
+USES= python
+USE_PYTHON= autoplist distutils concurrent allflavors
post-install:
${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/Cython \