aboutsummaryrefslogtreecommitdiffstats
path: root/lang/erlang-runtime16
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2014-10-09 20:53:42 +0800
committerJimmy Olgeni <olgeni@FreeBSD.org>2014-10-09 20:53:42 +0800
commit54838288f12c1df5526e7c74e1ea35bf9001911d (patch)
treea29bbe23fb42db47570063c9f28a9b909d05998f /lang/erlang-runtime16
parentea300678eba97e8b36a31e9698af95a32fadc2c6 (diff)
downloadfreebsd-ports-gnome-54838288f12c1df5526e7c74e1ea35bf9001911d.tar.gz
freebsd-ports-gnome-54838288f12c1df5526e7c74e1ea35bf9001911d.tar.zst
freebsd-ports-gnome-54838288f12c1df5526e7c74e1ea35bf9001911d.zip
Reduce diff with the main Erlang port and unmute install commands.
Diffstat (limited to 'lang/erlang-runtime16')
-rw-r--r--lang/erlang-runtime16/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/lang/erlang-runtime16/Makefile b/lang/erlang-runtime16/Makefile
index 33550caef838..24fdce3514e9 100644
--- a/lang/erlang-runtime16/Makefile
+++ b/lang/erlang-runtime16/Makefile
@@ -38,13 +38,14 @@ SCTP_DESC= Enable SCTP support
SMP_DESC= Enable SMP support
WX_DESC= Enable WX application
GS_DESC= Enable GS application (deprecated)
-DTRACE_DESC= Enable DTrace support (experimental)
+DTRACE_DESC= Enable DTrace support
OPTIONS_DEFAULT=SMP OPENSSL THREADS SCTP KQUEUE
ERL_RELEASE= R${PORTVERSION:S/.//g:tu:S/1$/-1/}
USES= gmake perl5
+USE_AUTOTOOLS= autoconf:env
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
@@ -62,9 +63,11 @@ DISTFILES+= ${ERLANG_DOCS}:erlangorg
# probes fixed does not match the number of defined probes (54 != 132,
# respectively)" you probably misconfigured DTrace in some way.
+.if ${OSVERSION} < 1000000
.if ${ARCH} == "amd64" && ${PORT_OPTIONS:MDTRACE} && ! ${PORT_OPTIONS:MGCC}
IGNORE= DTRACE support on amd64 requires GCC option
.endif
+.endif
.if ${PORT_OPTIONS:MGCC}
USE_GCC?= yes
@@ -165,12 +168,12 @@ post-install:
-C ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB} \
"man/man$${SECTION}/*.$${SECTION}" || ${TRUE}; \
done
- @${RM} -rf ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/man/cat?
+ ${RM} -rf ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/man/cat?
.if ${PORT_OPTIONS:MDOCS}
- @${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_DOCS} \
+ ${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_DOCS} \
-C ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}
- @${INSTALL_DATA} ${WRKSRC}/lib/dialyzer/doc/*.txt \
+ ${INSTALL_DATA} ${WRKSRC}/lib/dialyzer/doc/*.txt \
${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/lib/dialyzer-*/doc/
.endif