aboutsummaryrefslogtreecommitdiffstats
path: root/lang/erlang-runtime16
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-06 00:24:00 +0800
committerbapt <bapt@FreeBSD.org>2014-05-06 00:24:00 +0800
commit602652f5f498977ca9afddad82ce1abd529c8fdb (patch)
tree111c3e996440f35b3a05e66700954340c9919761 /lang/erlang-runtime16
parentc7c57f6ff3ff10dcbd4c447d7f21425e9de38302 (diff)
downloadfreebsd-ports-gnome-602652f5f498977ca9afddad82ce1abd529c8fdb.tar.gz
freebsd-ports-gnome-602652f5f498977ca9afddad82ce1abd529c8fdb.tar.zst
freebsd-ports-gnome-602652f5f498977ca9afddad82ce1abd529c8fdb.zip
Fix unixODBC vs libiodbc conflicts
Always rely on unixODBC each time a port is looking for libodbc.so Remove odbc compat from libiodbc This allows to install both kde and gnome at the same time While here: - Convert libiodbc to USES=libtool - Convert a bunch of libiodbc dependencies to USES=libtool - Chase libiodbc.so shlib change - Stagify some ports - Convert some ports to USES=pgsql Discussed with: rakuco (kde) With hat: portmgr
Diffstat (limited to 'lang/erlang-runtime16')
-rw-r--r--lang/erlang-runtime16/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/lang/erlang-runtime16/Makefile b/lang/erlang-runtime16/Makefile
index af3d7eb91650..2b578f7defba 100644
--- a/lang/erlang-runtime16/Makefile
+++ b/lang/erlang-runtime16/Makefile
@@ -30,8 +30,6 @@ PLIST_SUB= ERLANG_LIB=${ERLANG_LIB}
MAKE_JOBS_UNSAFE=yes
OPTIONS_DEFINE= GCC DOCS GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX DTRACE
-OPTIONS_SINGLE= ODBC
-OPTIONS_SINGLE_ODBC= IODBC UNIXODBC
GCC_DESC= Use current GCC
HIPE_DESC= Build native HiPE compiler
@@ -118,11 +116,7 @@ CONFIGURE_ARGS+=--with-wx-config=${WX_CONFIG}
.if ${PORT_OPTIONS:MODBC}
CONFIGURE_ARGS+=--with-odbc
-.if ${PORT_OPTIONS:MUNIXODBC}
-LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC
-.elif ${PORT_OPTIONS:MIODBC}
-LIB_DEPENDS+= iodbc:${PORTSDIR}/databases/libiodbc
-.endif
+LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
.else
CONFIGURE_ARGS+=--without-odbc
.endif