aboutsummaryrefslogtreecommitdiffstats
path: root/lang/erlang
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2016-01-20 18:30:04 +0800
committerJimmy Olgeni <olgeni@FreeBSD.org>2016-01-20 18:30:04 +0800
commit095a8ff1c78f3b7d3e37dd67c8d58a6c238473ec (patch)
tree22dccb5497f628d79cf4ecc672fbc1df976e9a08 /lang/erlang
parent7268d386d68266888f85c43143cc7cf12fbfacce (diff)
downloadfreebsd-ports-gnome-095a8ff1c78f3b7d3e37dd67c8d58a6c238473ec.tar.gz
freebsd-ports-gnome-095a8ff1c78f3b7d3e37dd67c8d58a6c238473ec.tar.zst
freebsd-ports-gnome-095a8ff1c78f3b7d3e37dd67c8d58a6c238473ec.zip
Improve the DTrace build for Erlang 18.
With a couple of changes it seems to work just fine when building as a user, and also inside poudriere jails. If you want to build in poudriere, you must: - Have dtraceall.ko loaded. - Have a kernel inside the jail (i.e. create the poudriere jail with -K).
Diffstat (limited to 'lang/erlang')
-rw-r--r--lang/erlang/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 1077608bbd63..2091018a9699 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -76,10 +76,6 @@ DOC_DISTFILES= armstrong_thesis_2003.pdf:joe \
programming_rules.pdf:erlangse
.endif
-# See http://wiki.freebsd.org/DTrace to learn how to enable DTrace
-# on your system. You will need to configure STRIP, WITH_CTF and
-# CFLAGS in your make.conf before building.
-
# If you run Erlang and get a message resembling "WARNING: number of
# probes fixed does not match the number of defined probes (54 != 132,
# respectively)" you probably misconfigured DTrace in some way.
@@ -96,6 +92,8 @@ USE_GCC?= yes
.if ${PORT_OPTIONS:MDTRACE}
CONFIGURE_ARGS+=--with-dynamic-trace=dtrace
+CFLAGS+= -fno-omit-frame-pointer
+STRIP=
.else
CONFIGURE_ARGS+=--without-dynamic-trace
.endif