aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc-aux
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-10-20 03:42:53 +0800
committermarino <marino@FreeBSD.org>2015-10-20 03:42:53 +0800
commitb4393b3a1f83fee08b2cfbfa4e25a8a35d67f16a (patch)
tree221b9565db678a49fb3c18c6bf05d09a207492ff /lang/gcc-aux
parent801c51f86208c1c0a15f5fabf0103740e889303c (diff)
downloadfreebsd-ports-gnome-b4393b3a1f83fee08b2cfbfa4e25a8a35d67f16a.tar.gz
freebsd-ports-gnome-b4393b3a1f83fee08b2cfbfa4e25a8a35d67f16a.tar.zst
freebsd-ports-gnome-b4393b3a1f83fee08b2cfbfa4e25a8a35d67f16a.zip
gnatdroid-sysroot: Add Android API Level 21 (Lollipop)
The latest Android Native Development Kit (NDK) has API Level 21 in it (but not 20, nor 22 or the latest Level 23). Add this option to gnatdroid's sysroot port, and change the default API from Jelly Bean 1 (Level 16) to Kitkat (Level 19). Bump gnatdroid's binutils and gnatdroid itself as a consequence of this default change. A new patch had to be added to lang/gcc-aux to handle the CTYPE changes which haven't made to GCC yet. Gnatdroid has been testing for building on all API's but not for functionality beyond Level 16 due to lack of hardware. I may soon install an Android emulator to see if that will suffice.
Diffstat (limited to 'lang/gcc-aux')
-rw-r--r--lang/gcc-aux/Makefile.version2
-rw-r--r--lang/gcc-aux/files/patch-libstdc++-v3_config_os_bionic_ctype__base.h21
2 files changed, 22 insertions, 1 deletions
diff --git a/lang/gcc-aux/Makefile.version b/lang/gcc-aux/Makefile.version
index 8e7def1650d0..277fede90eba 100644
--- a/lang/gcc-aux/Makefile.version
+++ b/lang/gcc-aux/Makefile.version
@@ -6,7 +6,7 @@ GCC_VERSION= ${GCC_BRANCH}.${GCC_POINT}
SNAPSHOT= 20150626
MAIN_PR= 0
UTIL_PR= 0
-ARMV7_PR= 0
+ARMV7_PR= 1
# Snapshot naming pattern
#IDENTIFICATION= gcc-${GCC_BRANCH}-${SNAPSHOT}
diff --git a/lang/gcc-aux/files/patch-libstdc++-v3_config_os_bionic_ctype__base.h b/lang/gcc-aux/files/patch-libstdc++-v3_config_os_bionic_ctype__base.h
new file mode 100644
index 000000000000..531c67e6dfa1
--- /dev/null
+++ b/lang/gcc-aux/files/patch-libstdc++-v3_config_os_bionic_ctype__base.h
@@ -0,0 +1,21 @@
+--- libstdc++-v3/config/os/bionic/ctype_base.h.orig 2014-01-02 22:30:10 UTC
++++ libstdc++-v3/config/os/bionic/ctype_base.h
+@@ -40,6 +40,18 @@ _GLIBCXX_BEGIN_NAMESPACE_VERSION
+ // Non-standard typedefs.
+ typedef const int* __to_type;
+
++#ifdef _CTYPE_U
++#define _U _CTYPE_U
++#define _L _CTYPE_L
++#define _D _CTYPE_D
++#define _S _CTYPE_S
++#define _P _CTYPE_P
++#define _C _CTYPE_C
++#define _X _CTYPE_X
++#define _B _CTYPE_B
++#define _N _CTYPE_D
++#endif
++
+ // NB: Offsets into ctype<char>::_M_table force a particular size
+ // on the mask type. Because of this, we don't use an enum.
+ typedef char mask;