aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc10-devel
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2019-11-10 21:10:55 +0800
committerGerald Pfeifer <gerald@FreeBSD.org>2019-11-10 21:10:55 +0800
commita4dc770f74a98395f3f32a4e4ac6fe8462b743cb (patch)
tree69a412a56a625a4d3330f954152e89569d3c86dd /lang/gcc10-devel
parentd5716de7288ab5e0ea42b9c5d4c957b636586004 (diff)
downloadfreebsd-ports-gnome-a4dc770f74a98395f3f32a4e4ac6fe8462b743cb.tar.gz
freebsd-ports-gnome-a4dc770f74a98395f3f32a4e4ac6fe8462b743cb.tar.zst
freebsd-ports-gnome-a4dc770f74a98395f3f32a4e4ac6fe8462b743cb.zip
Add a new option PLUGINS that enables GCC's plugin framework. This is off
by default for now, but something to possibly make the default after a bit of settling. I plan to backport this to lang/gcc9-devel and then lang/gcc9. Submitted by: David Carlier <devnexen@gmail.com> Differential Revision: https://reviews.freebsd.org/D22292
Diffstat (limited to 'lang/gcc10-devel')
-rw-r--r--lang/gcc10-devel/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/gcc10-devel/Makefile b/lang/gcc10-devel/Makefile
index 88d1ee9dac3d..249d73ce311e 100644
--- a/lang/gcc10-devel/Makefile
+++ b/lang/gcc10-devel/Makefile
@@ -43,7 +43,7 @@ SSP_UNSAFE= yes
CFLAGS:= ${CFLAGS:N-mretpoline}
CXXFLAGS:= ${CXXFLAGS:N-mretpoline}
-OPTIONS_DEFINE= BOOTSTRAP GRAPHITE
+OPTIONS_DEFINE= BOOTSTRAP GRAPHITE PLUGINS
OPTIONS_DEFAULT= BOOTSTRAP
BOOTSTRAP_DESC= Build using a full bootstrap
GRAPHITE_DESC= Support for Graphite loop optimizations
@@ -59,6 +59,8 @@ MULTILIB_CONFIGURE_ENABLE= multilib
CONFIGURE_ARGS+= --disable-multilib
.endif
+PLUGINS_CONFIGURE_ENABLE= plugin
+
.include <bsd.port.pre.mk>
.if ${ARCH} == amd64