aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc28
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2003-04-28 23:37:22 +0800
committerobrien <obrien@FreeBSD.org>2003-04-28 23:37:22 +0800
commitad26c91c3e9c0f792b126e9e4712480171a607ea (patch)
treecb7a3b09840055fb81bcf365a2e97cdeef2019ed /lang/gcc28
parent58098ee231609323313c91a27c5e6fb0cad66131 (diff)
downloadfreebsd-ports-gnome-ad26c91c3e9c0f792b126e9e4712480171a607ea.tar.gz
freebsd-ports-gnome-ad26c91c3e9c0f792b126e9e4712480171a607ea.tar.zst
freebsd-ports-gnome-ad26c91c3e9c0f792b126e9e4712480171a607ea.zip
Simpler version of the "make this work on 5-CURRENT again" fix.
In this version we simply use the default emulation rather than explicitly setting it [wrong].
Diffstat (limited to 'lang/gcc28')
-rw-r--r--lang/gcc28/Makefile5
-rw-r--r--lang/gcc28/files/patch-0211
2 files changed, 10 insertions, 6 deletions
diff --git a/lang/gcc28/Makefile b/lang/gcc28/Makefile
index 173f0d3dabc5..2d5d6fdeaa81 100644
--- a/lang/gcc28/Makefile
+++ b/lang/gcc28/Makefile
@@ -47,11 +47,6 @@ pre-patch:
@${MV} ${WRKSRC}/config/i386/freebsd.h ${WRKSRC}/config/i386/freebsd-aout.h
@${MV} ${WRKSRC}/config/i386/freebsd-elf.h ${WRKSRC}/config/i386/freebsd.h
-post-patch:
-.if ${OSVERSION} >= 500000
- @${REINPLACE_CMD} -e 's|elf_i386|elf_i386_fbsd|' ${WRKSRC}/config/i386/freebsd.h
-.endif
-
pre-configure:
@# Keep from running `autoconf' and `autoheader' since we modified
@# configure.in by patching it.
diff --git a/lang/gcc28/files/patch-02 b/lang/gcc28/files/patch-02
index 000b3b252434..e141d3a56714 100644
--- a/lang/gcc28/files/patch-02
+++ b/lang/gcc28/files/patch-02
@@ -1,5 +1,5 @@
--- config/i386/freebsd.h.orig Fri Dec 5 04:15:34 1997
-+++ config/i386/freebsd.h Sun Mar 21 17:59:06 1999
++++ config/i386/freebsd.h Sun Apr 27 15:12:42 2003
@@ -26,8 +26,18 @@
/* The svr4 ABI for the i386 says that records and unions are returned
@@ -29,3 +29,12 @@
#undef CPP_SPEC
#define CPP_SPEC "%(cpp_cpu) %[cpp_cpu] %{fPIC:-D__PIC__ -D__pic__} %{fpic:-D__PIC__ -D__pic__} %{posix:-D_POSIX_SOURCE}"
+@@ -176,7 +186,7 @@
+ done. */
+
+ #undef LINK_SPEC
+-#define LINK_SPEC "-m elf_i386 %{shared:-shared} \
++#define LINK_SPEC "%{shared:-shared} \
+ %{!shared: \
+ %{!ibcs: \
+ %{!static: \