aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc32/Makefile
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2002-03-09 17:00:59 +0800
committerobrien <obrien@FreeBSD.org>2002-03-09 17:00:59 +0800
commit1b73bcd48ab1f17817ae93df8c85ba4771ee6e93 (patch)
tree6718cd4f448a83e4d4c429ec511ca7942bb5abeb /lang/gcc32/Makefile
parentb8ec908e058be827bba0af961f33e23a449c7671 (diff)
downloadfreebsd-ports-gnome-1b73bcd48ab1f17817ae93df8c85ba4771ee6e93.tar.gz
freebsd-ports-gnome-1b73bcd48ab1f17817ae93df8c85ba4771ee6e93.tar.zst
freebsd-ports-gnome-1b73bcd48ab1f17817ae93df8c85ba4771ee6e93.zip
Upgrade to the 4-March-2002 GCC 3.1 development snapshot.
Diffstat (limited to 'lang/gcc32/Makefile')
-rw-r--r--lang/gcc32/Makefile25
1 files changed, 15 insertions, 10 deletions
diff --git a/lang/gcc32/Makefile b/lang/gcc32/Makefile
index a9689b10517e..bd9d6712721d 100644
--- a/lang/gcc32/Makefile
+++ b/lang/gcc32/Makefile
@@ -6,11 +6,12 @@
# $FreeBSD$
#
-SNAPDATE= 2002-02-25
+SNAPDATE= 2002-03-04
SNAPVER= ${SNAPDATE:S/-//g}
-PORTNAME= gcc31
-PORTVERSION= ${SNAPVER}
+PORTNAME= gcc
+PORTVERSION= 3.1
+PORTREVISION= ${SNAPVER}
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_SOURCEWARE} \
ftp://ftp.netwinder.org/pub/build/gcc/i386/${SNAPVER}/ \
@@ -134,14 +135,13 @@ post-install:
# These 3 libraries are moved from PREFIX/lib to avoid conflicts
# with the stock compiler.
${MV} -f ${PREFIX}/lib/libiberty.a ${TARGLIB}
- ${MV} -f ${PREFIX}/lib/libstdc++.* ${PREFIX}/lib/libsupc++.* ${TARGLIB}
- -${MV} -f ${PREFIX}/lib/ieee ${TARGLIB}
-#.if defined(WANT_SHAREDLIBS)
-# ${MV} -f ${PREFIX}/lib/libstdc++.so* ${TARGLIB}
-#.endif
-.for info in cpp cppinternals g77 gcc gcj
- install-info ${PREFIX}/info/${info}.info ${PREFIX}/info/dir
+.for file in libstdc++ libsupc++ libg2c libfrtbegin libobjc
+ ${MV} -f ${PREFIX}/lib/${file}.* ${TARGLIB}
.endfor
+ -${MV} -f ${PREFIX}/lib/ieee ${TARGLIB}
+#.for info in cpp cppinternals g77 gcc gcj
+# install-info ${PREFIX}/info/${info}.info ${PREFIX}/info/dir
+#.endfor
cd ${PREFIX} ;\
${FIND} ${TARGLIB:S/^${PREFIX}\///} -type f -o -type l \
>${WRKDIR}/PLIST.gcc-lib
@@ -157,4 +157,9 @@ post-install:
${CP} -p ${TMPPLIST} ${TMPPLIST}.pre-gcc-lib
cd ${WRKDIR} ; ex < ex.script
+chklatest:
+ ncftpls \
+ ftp://mirrors.rcn.net/mirrors/sources.redhat.com/gcc/snapshots/ \
+ | grep LATEST
+
.include <bsd.port.post.mk>