aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc32/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2005-03-21 01:53:04 +0800
committeradamw <adamw@FreeBSD.org>2005-03-21 01:53:04 +0800
commit3693c01c5e61733362c8758991db200e8eccb759 (patch)
tree62ce9a9ea5bba92fd529dac75968da1842e91e2e /lang/gcc32/Makefile
parent29f670f8ae52ff6c97295192471dcdd5134864cd (diff)
downloadfreebsd-ports-gnome-3693c01c5e61733362c8758991db200e8eccb759.tar.gz
freebsd-ports-gnome-3693c01c5e61733362c8758991db200e8eccb759.tar.zst
freebsd-ports-gnome-3693c01c5e61733362c8758991db200e8eccb759.zip
It was discovered that running "make clean" from a port with a dependency
on gcc31 or gcc32 (either with a BUILD_DEPENDS or via USE_GCC) with that version of gcc already installed causes infinite recursion problems. The issue stems from gcc31 and gcc32 using USE_GCC internally. Internally, it was used to override any other definition and say that you can use any gcc version to build gcc31/gcc32. But that USE_GCC redefinition was causing recursion errors, so handle the problem instead by just simply undefining USE_GCC inside the gcc port Makefile itself. This should make things happy again.
Diffstat (limited to 'lang/gcc32/Makefile')
-rw-r--r--lang/gcc32/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/gcc32/Makefile b/lang/gcc32/Makefile
index a916096c2a0f..b491517d50c3 100644
--- a/lang/gcc32/Makefile
+++ b/lang/gcc32/Makefile
@@ -31,8 +31,10 @@ USE_REINPLACE= yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
-# Do not require GCC 3.2 to compile -- or we have an infinite loop on RELENG_4.
-USE_GCC= 2.7+
+# Do not let USE_GCC be set here. We can't hardcode that gcc32 should require
+# gcc32 in order to build. Setting USE_GCC at all here causes recursion errors
+# when it clobbers the USE_GCC defined by other ports.
+.undef USE_GCC
NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>