aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc32/Makefile
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2004-03-14 02:05:38 +0800
committergerald <gerald@FreeBSD.org>2004-03-14 02:05:38 +0800
commit4ff04e539f171e4bc991114fb6ead3e90863321f (patch)
treee990623fb7695f305d2135ecfadcede81be3a209 /lang/gcc32/Makefile
parent0c336d1b42e40961e3f0b2bb74619bc8998d4ede (diff)
downloadfreebsd-ports-gnome-4ff04e539f171e4bc991114fb6ead3e90863321f.tar.gz
freebsd-ports-gnome-4ff04e539f171e4bc991114fb6ead3e90863321f.tar.zst
freebsd-ports-gnome-4ff04e539f171e4bc991114fb6ead3e90863321f.zip
Remove WITH_BOUNDSCHECKING knob, as the patch disappeared upstream and
GCC 3.3 with a current bounds checking patch should be better anyways. Reported by: trevor
Diffstat (limited to 'lang/gcc32/Makefile')
-rw-r--r--lang/gcc32/Makefile25
1 files changed, 0 insertions, 25 deletions
diff --git a/lang/gcc32/Makefile b/lang/gcc32/Makefile
index db53693edad2..5f2030a4ea6a 100644
--- a/lang/gcc32/Makefile
+++ b/lang/gcc32/Makefile
@@ -23,14 +23,6 @@ DISTFILES= gcc-core-${PORTVERSION}${EXTRACT_SUFX} \
MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 3.2.3
-.if defined (WITH_BOUNDSCHECKING)
-# Fetch another file, but don't extract it. Also add another patchfile.
-BCPATCH= bounds-checking-gcc-3.2.3-1.01.patch.bz2
-DISTFILES+= ${BCPATCH}:bc
-EXTRACT_ONLY= ${DISTFILES:S/${BCPATCH}:bc//}
-EXTRA_PATCHES= ${FILESDIR}/opt.patch-bc
-.endif
-
LATEST_LINK?= gcc32${PKGNAMESUFFIX}
USE_BZIP2= yes
@@ -85,23 +77,6 @@ MAN1= cpp32.1 g++32.1 g77-32.1 gcc32.1 gcov32.1 \
jcf-dump32.1 jv-scan32.1 jv-convert.1
MAN7= fsf-funding.7 gfdl.7 gpl.7
-pre-fetch:
- @${ECHO} "Making GCC ${DISTNAME:S/^gcc-//} for ${OPSYS} ${OSREL} ${PORTOBJFORMAT} target ${CONFIGURE_TARGET}"
-.if !defined(WITH_BOUNDSCHECKING)
- @${ECHO_MSG} "You can enable fine-grained bounds-checking support for compiled C programs"
- @${ECHO_MSG} "by defining WITH_BOUNDSCHECKING. Compile and link with \"-fbounds-checking\""
- @${ECHO_MSG} "to use."
-.endif
-
-.if defined(WITH_BOUNDSCHECKING)
-# Extract bounds-checking patch, removing the ada parts of the patch with sed.
-pre-patch:
- cd ${_DISTDIR} ; \
- ${BZCAT} ${BCPATCH} | \
- ${SED} -e '/^--- .*ada/,/^diff/d' | \
- ${PATCH} -d ${PATCH_WRKSRC} -E -p1 --quiet
-.endif
-
pre-configure:
cd ${SRCDIR} ; contrib/gcc_update --touch
@${RM} -f ${SRCDIR}/gcc/*/*.info*