aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc35
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2003-04-06 22:30:41 +0800
committergerald <gerald@FreeBSD.org>2003-04-06 22:30:41 +0800
commit01712de0f4c3b889f8d6e8321e3270db8276c93a (patch)
tree11ba2be39e682c13251b982190beb04cfdffcf3f /lang/gcc35
parentf5a702501ae6cef2e8f2e17940efb01265e1b720 (diff)
downloadfreebsd-ports-gnome-01712de0f4c3b889f8d6e8321e3270db8276c93a.tar.gz
freebsd-ports-gnome-01712de0f4c3b889f8d6e8321e3270db8276c93a.tar.zst
freebsd-ports-gnome-01712de0f4c3b889f8d6e8321e3270db8276c93a.zip
Appease portlint by various whitespace changes. Remove last traces of
PATCH_SITES and PATCHFILES which we haven't used lately as well as of libgcj not building properly.
Diffstat (limited to 'lang/gcc35')
-rw-r--r--lang/gcc35/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/lang/gcc35/Makefile b/lang/gcc35/Makefile
index 5a9758582b0f..ed2493a4d7e5 100644
--- a/lang/gcc35/Makefile
+++ b/lang/gcc35/Makefile
@@ -1,5 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: egcs
+# ex:ts=8
+# Ports collection makefile for: egcs
# Date created: 9 Jan 1998
# Whom: John Polstra <jdp@polstra.com>
#
@@ -65,18 +65,17 @@ CONFIGURE_ARGS= --disable-nls --with-gnu-as --with-gnu-ld \
#CONFIGURE_ARGS+= --program-suffix=33
# Java
CONFIGURE_ARGS+= --with-system-zlib #--includedir=${TARGLIB}/include/Java -libdir=${TARGLIB}
-#CONFIGURE_ARGS+= --disable-libgcj # does not bootstrap now
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
.if defined(WANT_SHAREDLIBS)
-CONFIGURE_ARGS+= --enable-shared
+CONFIGURE_ARGS+= --enable-shared
.else
-CONFIGURE_ARGS+= --disable-shared
+CONFIGURE_ARGS+= --disable-shared
.endif
.if defined(WANT_THREADS_SUPPORT)
-CONFIGURE_ARGS+= --enable-threads
+CONFIGURE_ARGS+= --enable-threads
# ?is this an ObjC only thing?
-CONFIGURE_ARGS+= --enable-threads=posix
+CONFIGURE_ARGS+= --enable-threads=posix
.endif
ALL_TARGET= bootstrap
MAN1= cpp33.1 g++33.1 g77-33.1 gcc33.1 gcov33.1 \
@@ -109,9 +108,6 @@ do-fetch:
${ECHO_MSG} ">> Please try again later."; \
exit 1; \
fi
- @${TEST} -e ${DISTDIR}/${DIST_SUBDIR}/${PATCHFILES} \
- || fetch -o ${DISTDIR}/${DIST_SUBDIR}/${PATCHFILES} \
- ${PATCH_SITES}${PATCHFILES}
do-extract:
${MKDIR} ${SRCDIR}
@@ -220,8 +216,8 @@ post-install:
cd ${WRKDIR} ; ex < ex.script
cklatest:
-.for SITE in ftp://gcc.gnu.org/pub/gcc/snapshots/ ftp://mirrors.rcn.net/mirrors/sources.redhat.com/gcc/snapshots/
- @-ncftpls ${SITE} | grep LATEST
+.for SITE in ftp://gcc.gnu.org/pub/gcc/snapshots/ ftp://mirrors.rcn.net/mirrors/sources.redhat.com/gcc/snapshots/
+ @-ncftpls ${SITE} | ${GREP} LATEST
.endfor
.include <bsd.port.post.mk>