aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc35
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2004-01-10 06:04:51 +0800
committergerald <gerald@FreeBSD.org>2004-01-10 06:04:51 +0800
commit34ca2004164f8755e745556b661d166a4aaedfd4 (patch)
treea2e60038ae18294f472bd8bb87b3335c760e4c86 /lang/gcc35
parent4d6cccfc60006b2becf40fa27934a13a4228430c (diff)
downloadfreebsd-ports-gnome-34ca2004164f8755e745556b661d166a4aaedfd4.tar.gz
freebsd-ports-gnome-34ca2004164f8755e745556b661d166a4aaedfd4.tar.zst
freebsd-ports-gnome-34ca2004164f8755e745556b661d166a4aaedfd4.zip
Fix packaging which was quite broken. On the way, update PORTVERSION to
match the new versioning scheme in GCC-land and adjust the renaming of gccbug to the scheme used by the other programs installed by this port.
Diffstat (limited to 'lang/gcc35')
-rw-r--r--lang/gcc35/Makefile11
-rw-r--r--lang/gcc35/pkg-plist2
2 files changed, 6 insertions, 7 deletions
diff --git a/lang/gcc35/Makefile b/lang/gcc35/Makefile
index 3ab667bf30ae..364ac5ba9453 100644
--- a/lang/gcc35/Makefile
+++ b/lang/gcc35/Makefile
@@ -10,10 +10,10 @@ SNAPDATE= 2003-12-31
#CVS_DATE= ${SNAPDATE} 18:53:04 EDT
PORTNAME= gcc
-PORTVERSION= 3.4
+PORTVERSION= 3.4.0
PORTREVISION= ${SNAPDATE:S/-//g}
CATEGORIES= lang java
-VERSIONSTRING= ${PORTVERSION}-${PORTREVISION}
+VERSIONSTRING= 3.4-${PORTREVISION}
MASTER_SITES= ${MASTER_SITE_GCC} \
http://web.inter.NL.net/hcc/Haj.Ten.Brugge/:bc
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -44,11 +44,10 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-GCC_VER= ${PORTVERSION:C/\.0$//}
SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
-TARGLIB= ${PREFIX}/lib/gcc/${CONFIGURE_TARGET}/${GCC_VER}
-PLIST_SUB= GCC_VER=${GCC_VER} GNU_HOST=${CONFIGURE_TARGET}
+TARGLIB= ${PREFIX}/lib/gcc/${CONFIGURE_TARGET}/${PORTVERSION}
+PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET}
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BISON= yes
@@ -143,7 +142,7 @@ post-install:
|| ${MV} -f ${PREFIX}/man/man1/${f}.1 \
${PREFIX}/man/man1/${f}-34.1 )
.endfor
- ${MV} -f ${PREFIX}/bin/gccbug ${PREFIX}/bin/gccbug-${PORTVERSION}
+ ${MV} -f ${PREFIX}/bin/gccbug ${PREFIX}/bin/gccbug34
# These 3 libraries are moved from PREFIX/lib to avoid conflicts
# with the stock compiler.
.for f in libstdc++ libsupc++ libg2c libfrtbegin libobjc ${EXTRA_SHLIB}
diff --git a/lang/gcc35/pkg-plist b/lang/gcc35/pkg-plist
index 182357f13a85..63ed478b829e 100644
--- a/lang/gcc35/pkg-plist
+++ b/lang/gcc35/pkg-plist
@@ -9,7 +9,7 @@ bin/%%GNU_HOST%%-gcc34
bin/%%GNU_HOST%%-g++34
bin/%%GNU_HOST%%-gcj
bin/%%GNU_HOST%%-gcjh
-bin/gccbug-%%GCC_VER%%
+bin/gccbug34
bin/gcj34
bin/gcjh34
bin/gij34