aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc40
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2004-03-17 22:21:58 +0800
committergerald <gerald@FreeBSD.org>2004-03-17 22:21:58 +0800
commit0c8f97a3b5897b32badc8fb0506b9386f055f6fc (patch)
tree9cf6558a1bd9fb1f669bb7420a6f888736ca7a5c /lang/gcc40
parentd41817a3e3c1bd72ba929a677eb5c4c6308eddf1 (diff)
downloadfreebsd-ports-gnome-0c8f97a3b5897b32badc8fb0506b9386f055f6fc.tar.gz
freebsd-ports-gnome-0c8f97a3b5897b32badc8fb0506b9386f055f6fc.tar.zst
freebsd-ports-gnome-0c8f97a3b5897b32badc8fb0506b9386f055f6fc.zip
Try to fix breakage of non-amd64 platforms introduced by 1.165 and
remove inflamatory comment. Remove BROKEN from sparc64 and simplify special case handling of libgcj on ia64 and sparc64. USE_SIZE is now the default, no need to specify it explicitly. Remove WANT_THREADS_SUPPORT knob, which should be a no-op by now.
Diffstat (limited to 'lang/gcc40')
-rw-r--r--lang/gcc40/Makefile16
1 files changed, 3 insertions, 13 deletions
diff --git a/lang/gcc40/Makefile b/lang/gcc40/Makefile
index 8ff31da6c6b5..2a315db2fd2a 100644
--- a/lang/gcc40/Makefile
+++ b/lang/gcc40/Makefile
@@ -33,7 +33,6 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5_BUILD=yes
USE_REINPLACE= yes
-USE_SIZE= yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
@@ -42,16 +41,12 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-# fscking Linux & GNU $*!%
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
-.if ${ARCH} == sparc64
-BROKEN= "libgcj is not supported/packaging is broken on this platform"
-WITHOUT_LIBJAVA= yes
-.endif
-
-.if ${ARCH} == ia64
+.if ${ARCH} == ia64 || ${ARCH} == sparc64
WITHOUT_LIBJAVA= yes
.endif
@@ -74,11 +69,6 @@ EXTRA_SHLIB= libgcc_s
.else
CONFIGURE_ARGS+= --disable-shared
.endif
-.if defined(WANT_THREADS_SUPPORT)
-CONFIGURE_ARGS+= --enable-threads
-# ?is this an ObjC only thing?
-CONFIGURE_ARGS+= --enable-threads=posix
-.endif
ALL_TARGET= bootstrap-lean
PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET}
MAN1= cpp${SUFFIX}.1 \
.cgi/freebsd-ports-gnome/commit/math/coq?h=gnome-3.26&id=a011ad07cf2ca7a78034dc7c8599a46e3ecb8840'>Update to 8.2.1johans2009-03-163-106/+531 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-061-1/+1 * - Due to depency updates, camlp5 (fresh port) is now required as well:johans2008-04-171-0/+3 * - Update to 8.1pl3johans2008-04-073-7/+7 * Update to 8.1.1 (bugfix release)johans2007-07-303-6/+10 * - Welcome X.org 7.2 \o/.flz2007-05-201-0/+1 * - Update to 8.1johans2007-03-263-277/+137 * - Update to 8.0pl3pav2006-03-163-20/+15 * BROKEN: Does not buildkris2006-03-071-0/+2 * Replace ugly "@unexec rmdir %D... 2>/dev/null || true" with @dirrmtryedwin2006-01-221-4/+4 * Unbreak: Add vendor-patch for ocaml 3.09vs2005-12-072-0/+5 * Bump PORTREVISION to regenerate the package with the newly enabled IDE on the...vs2005-12-051-0/+1 * Enable IDE by default.vs2005-12-051-3/+3 * - Add SHA256pav2005-11-251-0/+1 * Drop MAINTAINERmnag2005-10-301-1/+1 * Update to 8.0p2vs2005-02-022-10/+5 * Fix packagingvs2005-01-192-8/+7 * - Unbreak on amd64sem2004-12-211-2/+1 * Mark broken on ia64 and amd64.tobez2004-11-291-0/+4 * - Add optional CoqIde support (depends on lablgtk2)pav2004-11-093-58/+69